E011 full throttle oscilations


#1

Im in level mode when it oscilates, will try in acro later today.
I’m stuck using the toy tx while a new multiprotocol is shipped to me. But it did it with the flysky i6 just not as noticeable. It’s seems around 80% 85% throttle and above i have crazy oscilations. The whoop acts like it is getting constant pitch and roll input. I know it could be a million different things.
Whoop setup
E011 stock frame , motors, fc, and props,
Lst s2 aio vtx,
Lego lid cut down to a thin strip to hold vtx.
With 260mah 45c lypos it weighs 31g’s


#2

Curious how it behaves in acro. I’ve flown level maybe a dozen times now … definitely not enough exposure to be helpful diagnosing an issue from angle behavior.


#3

quick update
new multiprotocol will be home today. But I remembered I had dropped the throttle curve in the flysky tx down from 100 to 98.(The stock software would lift up at 100% throttle, kinda hard to fight the wind.) Gonna reset throttle curve on fs i6 tonight. I’ll test acro/level on both the tonight. Gonna attempt to hack the camera from syma x5c to use as fpv camera and cheap dvr. Is the 3 pin slot on the e011 board recognized by silverware?


#4

Yes it’s recognized but it requires some setup in code. Are you running my fork of silverware or the main repo?


#5

Yours good sir.


#6

The new multiprotocol does the same thing as the old one. Led Flashes fast for a few seconds then goes solid like it’s bound. But the e011 (it’s the same on both stock firmware and silverware) is still flashing fast looking to bind.
Maybe default or reflash txs software?
I tried creating a new model but to no avail…


#7

Do you have the right channel order in your model on your TX?

The channel order assumed in all the documentation is AETR. You can change this in the compilation settings. The module will take whatever input channel order and will rearrange them to match the output channel order required by the selected protocol.


#8

That was the issue I had with my module and as soon as I set it right it lit up and bound with no further issues.


#9

Wonderful news!!!


#10

I was really thinking that was gonna be the issue. But alas it still in mode 2
I’m hoping when my leader 120 gets here in the next few days that it doesn’t have an issue binding.
It reminds me of how the multiprotocol won’t bind if you bump a switch or the throttle just as you attach the battery. Then as soon as you fix the switch or throttle it binds right up.
I say that cause I left silverware nfe stock.
I didn’t check the switches order or anything. When the multiprotocol came out the day it started having issues, I moved the 2 rolling knobs in the center of the tx. I hadn’t moved them as far as I know before that moment. It did bind 1 more time after that


#11

I’ve noticed my back ducts are angle out or down from the frame center. (Anhedral) I’ll bet that causes more oscilations than pid settings will.
From a linear perspective at least.
Gonna get some gorilla CA glue from hobby lobby tomorrow to fix broken strut on other frame.
Perhaps I can use the sowing needle thing to align rear ducts.


#12

For what it’s worth regarding binding… I did put safety features in my fork that stop anything from happening if you attempt to bind with arming in the armed position. Also stops you if you attempt to arm with throttle above 0. You can disable those safeties by commenting out arming and idle up features in the receiver section. The bind actually occures… but the error message returned via led flashing makes it appear that a bind did not conplete.


#13

Interesting I’ll try flipping all the switches to see if that fixes it. What about hooking up through the ppm pad? Anyone tried this yet? Haven’t found much info on hooking up using ppm on flysky i6