E011 7mm Newcomer - Now hacked for acro


Just the super fast flash … ie waiting to bind? Or a specific code of flashes?

And just to make sure I understand … using the b03 file from github - the included .hex will flash in utility and work but if you build one with keil from that same project it doesn’t bind?


The .hex file i made in keil was the silverware e011 dual mode and i flashed it with the st link utility. The .hex file that i flash and can bind and fly with is the boldclash bwhoop b-03 master bin .hex file from github. The file i made from e011 .hex file comes out a bwhoop.hex file not a e011.hex file so i figured it would work but just the constant rapid flashing leds. i plug in the quad it blinks kinda slowly but normal sequence when i turn on tx it beeps like it binds but then the leds instead of constant on like it is in bind it flashes rapid constant flash. maybe i could make a small video and upload it from my phone of the binding or non binding it is doing. well it wont let me upload video from my phone do you have messenger i could send it that way maybe


No need. The e011 project will output a hex called bwhoop… but it’s still an e011 file regardless of what it’s called. Nothing e011 will work on your board. Clean them all off your computer so you don’t get confused. Go back to the bwhoop github project and try to flash with keil. Tell me what happens there.


ok let me do that real quick. I just finished with the project build and it says 0 errors and 19 warnings whats that mean will that mess up the fc if i flash that with warnings


I wouldn’t flash that. Stand by… I’ll build you a hex.


thanks been 2 days usually if i tinkerlng enuf i can figure something out but this time is just driving me nuts mainly because i really have no programming background this stuff intrigues me but have n idea were to start this is a crash course i guess rofl. just wondering is there a way once i get a working .hex can i open it in keil and modify it for pid’s or tx button switching functions, and will this work for my h67 for my flysky tx did not see the h67 in spec list and unsure of protocols


No you have to have a multimodule installed in your radio to make a h67 work.

Flash this hex and let me know if it works. Rates button should arm it… flip button should switch between acro and level. trims should work. Ive not tried this before on the toy tx so cross your fingers.
bwhoop.zip (15.5 KB)

And keep trying to learn this stuff … it gets easier @RedneckMcguyver


iRangeX iRX6 Multiprotocol TX Module for Flysky FS-i6 i6x Transmitter like this one. I will give it a shot and hope for the best


No link but that sounds right. Of course if this file does work … it will require more changes to work with a real tx. Lol. But we’ll cross that bridge later.


ok it binds and works just the arm switch not sure but i think it is affecting throttle to much i drop throttle to zero and it still goes i do not have a camera to compensate for the weight i did read that in one of these forums that being a issue and it only acro no lvl when i hit the flip button. The rates are supa fast roflmfao i am beginner but it will be ok just can not fly indoors with these rates. The throttle after i get it into the air and i go to crash i kill the throttle but it still keeps going like i never dropped the throttle i have to disarm and rearm motors to get it to stop


Does level mode work on stick gestures? Right stick … right right down or left left down


never thought to check that 1 sec well let battery charge real quick wont even lift off ground


Tape a coin to it for a little ballast to see how it flies also. ideally about 4 or 5 grams.

I also already made some changes to compensate for no camera … it shouldnt have gained altitude after arming. I wonder if this will work on the toy tx…


i got a beefy zip tie on it to protect the board antennae and crystal that slowed it down with the original bwhoop hex i was flashing, let me throw santa on it and see if that counters the motors. it doesn’t gain altitude after i arm it it sits there but when i start flying around the motors don’t like to unspool down to idle they stay at a hover type speed when i drop throttle. no soft landing unless i hit the arm/disarm switch it just hits w/e and motors spool away like it is still trying to fly. is there a way to set idle speed like i see in youtube videos in betaflight so i can set motors at a lower rpm on arm maybe.waiting for battery to charge atm he made me a custom .hex for arm switch on stock tx and the acro/level mode on the flip button but lvl mode not work that way and forgot the gesture l,l,d and r,r,d for mode switch lol. I don’t care what mode it starts in just want both modes this h67 won’t flash anything but a friggin .hex file keil is worthless to me can’t even make my own .hex files. one of the motors kinda feels gritty like something inside is dirty. I plugged in the battery and tried the gestures for level and acro it did not work and i paid closer attention to motor speed the motors spool up and stay spooled up kinda like it has altitude hold even when i drop throttle to 0 it motors do not loose any speed they keep the same rpm at full throttle as they do at 0 input on throttle stick. I am past my newbie reply for the day that sux could you link the original silver13 file for me cant find it.I feel like an idiot rofl been flashing this thing all night drinking coffee i lnked the friggin thing earlier roflmfao been a long night. well the arm/disarm is buggy i gotta hit headless mode and then the flip button to arm motors and no idea if it has level mode because it only stays in the air for about 5-10 seconds then falls out of the air like it just turns itself off, and it beeps the whole time like it is in headless mode when the motors are spinning


If you want it to be in level mode at startup have a look at this:
“…This is the line where AUX 1 is enabled as the level/acro switch, and the default firmware setting looks like this:

// level / acro mode switch
The code below determines whether AUX 1 is on or off at powerup. For example, if your quad powers up in acro mode, and you want it to power up in level mode, then comment or uncomment this line:

// aux1 channel starts on if this is defined, otherwise off.
#define AUX1_START_ON…”



Ok… my file is tweaked for high performance fpv and has minimal filtering. Check your props for vibration or any damaged blades. It should fly perfect with the weight of a camera added. Something is wrong. Blow on the props while pinching the motor - feel for vibes and do a visual inspection for a bent blade

The problem with it not idling down is d term amplifing some kind of vibration

Next step would be to abandon my version of the software and go back to the stock file on github from silver13. It’s probably fine for line of sight flying.

@chrisdo - I took his level mode switch off of auxiliary 1 and put it on the flip channel. Although that’s not working … I don’t think toggling the start up state of aux will change it anymore. If stick gestures work it should though. But he can’t built a hex in keil himself for some unknown software issue



Try this file before you give up.

I put level mode/acro back on stick gestures, put low rates back on the rates button, and put arming on the flip button - and loaded up the default pids for line of sight. It should fly ok even with no added weight and a bad motor.

bwhoop2.zip (15.5 KB)


Been following this topic, lots of great info!

I am currently waiting for my ST-link and have a B03 pro and an E011 on standby to be flashed. I haven’t done this yet, so my question is this: is one better than the other? Any major differences in the boards that make it better to do one first? I know this is going to come with a bit of a learning curve so I wanted to set myself up for as much success as possible. Makes sense to just figure out one of them first I thought.


No advantages either way. Just 2 different files. The video Canino made is the reference I like. That procedure always works for me on a new board. Every step and detail is important - you’ll be fine! I love these boards and use them for all builds brushed now… not just whoops.


Decided to try this out on my e011. I have been doing FPV for 3 months and wanted to try acro on this before flying anything bigger.

I am having the same problems with flashing from Keil. I am able to flash from the ST-Link utility using the compiled .hex file from Keil. I think the problem with Keil might be the installation of the packs. I just downloaded and installed everything today. When I loaded the silverware project it auto downloaded and install one package, but then told me it needed another one and it could not find the pack. Looks like the STM32F0xx_DFP was updated on 1/18/18 so maybe that has something to do with it?

Was wondering if you could help me figure out what to modify to get my Flysky FS-i6 working. I have the tyrannis 4in1 module soldered and working in bayang protocol but I am not sure what to change in the config.h to get the acro/level mode to work. The arm switch works on channel 6 when set to ch5 in config.