Micro Motor Community

E011 7mm Newcomer - Now hacked for acro


Hey guys new here and to drones i bought a h67 and a st link followed the canino youtube guide it flashed but it would not bind. I unplugged it and tried again nothing just really fast flashing light. i googled it after a few hours of thinking i killed a new quad,saw a post were guys did same thing said his antennae was grounded out so i lifted it up and it bound but will only bind with the b-03 .hexx file nothing else flashes and lets the quad and tx bind, so basically i flashed it with dualmode b-03.hex any ideas for why it won’t bind to any other flash used notfastenuf dual mode/acro only and silverware’s flash’s all of them acted the same way maybe it was something i needed to change in a file or config somewere no clue am new to this flashing stuff.


Hey RedneckMcgyuver
Try flashing “Eachine-E011-master/Silverware/silverware.uvprojx” from the main github for Dual Mode

or Amazing Acro only: E011 7mm Newcomer - Now hacked for acro (file post 268)

EDIT: Sorry this is for E011


have tried that now and still just crazy fast lights do i need to change the radio protocol selection to my tx and how do i know what the stock tx is


for some reason everytime i try t flash it in keil the led’s do the rapid blinking and never binds but when i flash it with a .hex with the st link driver thing it works makes no since t me


sorry but will the fs-i6x work as tx with the multi protocol adapter thing did not see the h67 on the spec sheet for it ?


H67 board takes the same code as a b03. My e011 code is modified from the b03 to work on the e011. I have a Santa file I can upload fir you later that will work on your h67 and your specific tx.


oh man that would be greatly appreciated because none of the trim buttons or anything works for it just basic acro/level and high low speed i am using the stock jjrc h67 tx actually have a fs-i6x just got with x6b receiver don’t think that will work but if you know of a way to wire it up to work i would friggin hug you. I have one question and not sure if it is a glitch in the w/e keil is doin or not but nothing i do i keil has worked so far ust been able to flash .hex files from the st link app driver thing.


You have to connect to your board with the stlink utility program … then disconnect … then you can flash with keil.

Try that … even if it’s the wrong file. Since you want to use the stock tx - we may need to make a few changes to get that working right. Exactly which one of my links included the .hex file that worked to get it in the air? The old acro only one?


i’ll link it if i can


boldclash-BWHOOP-B-03-master/bin/bwhoop_default.hex is what makes it fly i have flashed with keil it connects i have retried it a few times checking thinking i might have done something wrong was almost ready to stomp it rofl then i had it flashed with this and the anntenae was shorted i moved it and was airborn again thinking it was just short tried too reflash dual and acro only with keil but just got crazy lights and no bind



Yep, you need a bwhoop b03 file and not an e011 file. Silver’s stock file doesn’t have any of my sweet tuning goodness in it. Hopefully I can convince him soon to make my tune the defaults. OK… and it sounds like you can successfully comet tge flashing process with keil… you just need the right file. I will make an attempt to set up one for the stock tx and keep you posted. You can btw use an Irange multimodule with your irange radio and scrap that stock tx.


Also, if you flash the file from github with keil it works right? Just not my e011 stuff?


thats not the exact file i have flashed atm but that bin .hex file flys the folder i have has has default and default new with pid gestures the pid gestures actually work no clue what i am doing but the blinks worked i tried them each out lol. no only way i can flash is with the st link utility let me try it again you said to connect it with st link then disconnect open your project file in keil by dbl clicking the green project file icon it opens the file in keil i hit project build then erase then program/flash then disconncet it


it actually flashes in keil says no errors no warnings but something won’t let the tx bind to the quad just fast flashing leds


just followed the steps i said w/o modifying anything to see if me switching the rear motor // things was doing it still crazy lights no bind. but now i can reconnect with st link utility and flash the boldclash bwhoop default new.hex with st link utility it gives me bind and i can use the acro/level gestures and the pid adjustments gestures no trim those buttons just beep no action. Thats the only way i can get a flying flash is with st link utility .hex file


Strange. Well you can use keil to make changes to code and then build target and pull out the .hex file you create with keil. It’s in the objects folder. I need to look at the files to get an idea what to change from next. I’ll stay in touch.


ok thnx will try that was wondering if i could convert keil to .hex but found nothing you helped a bunch maybe i can get it to work that way.


Are you willing to sacrafice tge flip function for arming/idle up?


sure flips suck auto anyways. i tried the hex file from the objects folder and it still did the same thing when flashed in the st link utility.