Micro Motor Community

E011 7mm Newcomer - Now hacked for acro


Thanks for the quick response, but that did not work. I spent some time changing a few settings, flash, repeat, etc. and got it working with the “7mm whoop” files from Nov. There were only two changes needed. Sets Arming to channel 6 on tx and acro/level mode to channel 5 on tx.


Also commented out the
//#define AUX1_START_ON

1 Like

You should be able to make those same changes in the file I just linked. What happens (or doesn’t happen) when you do? Worst case you’re not musing out on much yet. All the files fly pretty darn good. The biggest improvement is yet to come and I may be able to convince silver to make my tune the defaults - he is testing it out on his e011 now.


What multimodule are you using on your tx?


Here is the video that I followed on soldering the 4in1 module to flysky FS i6. Works great with my e010 and e011. Should work with many others as well.


I don’t know that one, but I’m sure it works great. I have the IR6X module and found that DEVO_CHAN_5 and 6 work in place of AUX_1. Also make sure on your tx that your aux 1 and 2 are mapped to your preferred switches and not the knobs.


Guys I’m starting a NFE Silverware specific thread for testing my silverware tunes. Essentially trying to get more organized, get on github, and make the process easier for you. In other words, I’m moving the silverware flashing portion of this discussion here


Anybody know how pid.c affects angle_pid.c?
In angle_pid.c it says:

// acro pids are also used at the same time in level mode
But doesnt really say how… is it cascading? Are the angle_pid’s a multiplier of pid.c?
Do the PID’s in angle_pid override the ones in pid.c?

Thanks for any clarity!


Think of angle p like leveling strength. You’re flying on the regular pids and the angle p just determines how hard it pushes back to level when you let the stick center.

1 Like

Hey guys I need your help.
I have the E011c and want to use it with my taranis.
I bought the cheap multiprotocol module from Banggood.

The Taranis works with the stock firmware and with the firmeware @NotFastEnuf has compiled for RedneckMcguyver.
When I compile the code with Keil it won’t work. It doesn’t bind.

What can I do?


Does it bind to the stock tx? If not then you have a bigger problem.
If it does bind there’s a good chance that something is wrong with your tx setupwise. Create a new model and go through the steps slowly to make sure you don’t miss anything.

1 Like

No, it doesn’t bind with the stock tx either. But I can still flash firmware which works.
It might has something to do with the changes in the code due to it is the christmas edition.
By the way, I always flash with the st link utility since Keil brings up an error when trying to install the packages for the usb programmer.

1 Like

Ok … yes the Christmas edition will not bind with the e011 board type selected in my silverware version. Head back to my github fork and download yourself a fresh zip. Open that project in Keil and go to the config.H file. Right on top is a hardware selection which by default is on e011. Comment out e011 and select bwhoop. Then set your transmitter selection to multi and flash away! ! You should be fine then. If not, let me know - and I will fix whatever the problem is in my code!

1 Like

Ahh. Never read this before. Thanks for the quick response. I’ll try when I come home today.


Cool… it should work then. I attempted some pretty clear instructions in the readme on github. Give them a look over. There are also notes in config about which selection to make for tge e011c (Christmas) - but for what it’s worth you will be the first guinea pig testing out my Bwhoop code in my latest version. Lol. Ive got my fingers crossed!

1 Like

That is so easy now! Worked on frist try. Unfortunately I can’t test it properly since my son is sleeping already. I’ll let you know how it flys. Thanks for your awesome help!


Are you using stock Tx or multi protocol Tx?


Mine came in straight as an arrow. Bg just wraps the product box. Try boiling for a few minutes use a pair of tongs to remove and lay on a flat surface. Soften the plastic to straighten it out. Never tried it with a kwad frame but I know for a fact it works with disc golf discs. So why wouldn’t it work on this…

1 Like

I flew this with my Deviated Devo 7e using multi-protocol module.


I’m being lazy and impatient but on the e011 board there is a 3 hole slot

What is it for?


On the Bwhoop board there is a connector soldered, it is used for the FPV camera.