E010S setup question


#41

Everything needs to be done with the transmitter on before the board is plugged in. Verify 1500 middle with tx on. Also, I’m assuming the ranges you reported before were with the transmitter on … Please correct them for me if not. Those exact values will be important for the next step.


#42

I unplugged the board, turned on the transmitter and then plugged in the board.

The min/max values are as I repored above 1144/1862


#43

The screen shot is this:


#44

Ok, that’s not right on the money but close enough for the next step.

Copy the text below and paste it into the bar at the bottom of the cli tab. Press enter. Then type the word save and press enter.

rxrange 0 1144 1862
rxrange 1 1144 1862
rxrange 2 1144 1862
rxrange 3 1008 1862

Another side note : the fact that aux 2 is moving with throttle indicates that some sort of “heli” based setup on your transmitter is giving you problems. That is a collective pitch type mix. If you have an airplane setting as opposed to heli in your radio - switch over to airplane. It would be nice for you to have a switch that you have control over instead of throttle.


#45

Then go back to receiver tab, still with radio on and actively able to move the bars and see if we get 1000 to 2000


#46

OK all are 1000-2000 except throttle which is 999-2000


#47

That will do. Ok. Next, still with radio on, adjust subtrim or trim on your transmitter to get closer to 1500 on the yaw channel. Verify pitch and roll are still as close as they were before too.


#48


#49

Perfect, great job. Now crank yaw deadband up to 8 and rc deadband up to 8 on that page.

Next, still with radio on. Go to modes tab and cancel out anything that you had next to arm so that it’s blank and click save.

Then on your left stick … throttle down and yaw right. The board should arm. Report if the icon on top of the configuration lights up. (Triangle with exclamation point)


#50

BINGO!


#51

OK great … now we’ve just got started. We need to set up everything else next. Hahaha

First question … how do you fly? Auto level or rate mode?


#52

Well ,I assumed that it was ready to fly and tried it. When I plugged in the battery and armed it, the motors started spinning. I gave it some throttle and it took off and crashed. Then I couldn’t get the motors to turn off. Turned off the transmitter, no luck. Finally got the battery disconnected. Maybe the Failsafe needs to turned on?

“Auto level or rate mode?” I have no idea what you mean by this.


#53

I’m also worried about your radio with it moving that aux channel linked to throttle. Do me a favor and double check that your bars aren’t moving 2 at a time when you move only one stick.


#54

OK got ya. Check the last thing with the receiver tab and report back. Ready to fly just means you get all the physical stuff you need. They are seldom but never ready! Ha!


#55

The Throttle and AUX2 are the only two that do this.


#56

Ok, next go to modes tab and assign angle to aux one. Open the bars up so the whole range activates it. Click save and make sure it lights up.


#57

Then go to your pids tab, screenshot it and post it.


#58


#59

Excellent walk through @NotFastEnuf
One thing is to zero all trims before rxrange figures are read. Unknown tx is a slight problem but you’ve got it nailed. :+1:


#60

Also need a shot a little lower in the screen.