E010S setup question


#21

After viewing a few videos, I believe my problem has something to do with CH5.

On my transmitter, there is a function called “Monitor”. It displays on the transmitter’s screen, the various flight controls. However, nothing seems to affect the CH5 slider; none of the sticks or any of the switches.

I do note however that if I hold the spring switch on the upper left (rear) of the transmitter, the transmitter’s display shows “BIND” when I power the transmitter on.

On the Modes panel, I changed the ARM from AUX1 to AUX5 and now the Arm indicator is enabled.

However, after unplugging the USB and trying to fly, nothing happens and now the arm indicator is dark.

Also, the lowest Throttle value that I can set using the trim switch is 1006. Max is 1861.

Bottom line: although I’ve managed to somehow get the ARM indicator to come on, it’s not persistent.


#22

Other than throttle at 1006 ( should work) have you followed the above procedures?


#23

I can consistently get the ARM indicator to come on if I:

  1. plug in the USB
  2. calibrate the Accellerometer (don’t think whether I do this makes any difference).
  3. open the Modes panel.
  4. click on the ARM “Add Range” button.
  5. Change “AUX1” to “AUX5”
  6. Click on “Save”, yellow ARM indicator is no on.

After this, I can disconnect the USB by clicking on the Red Disconnect button.
When I again click on the green Connect button, the ARM indicator is yellow.

Disconnect the USB cable.
When I Plug in the USB cable and the device connects, the yellow ARM flashes on then stays off. If I then go to the Modes panel, and lick on “Add Range”, "AUX 1 appears where it had been AUX 5.

It looks like it is not saving this option and powering off the device causes the value to be lost.


#24

That is strange. Calibration of the accelerometer is just a one time thing. After you assigned aux 5, and if you turned your radio on before plugging in USB. … you should be able to see the action of flipping the switch on your radio displayed on the modes tab under the arm sliders.

Wierd that it won’t save your aux 5. I’m stumped on that.


#25

Hey guys
Just briefly (quickly) read through the thread.
I have no experience w that tx, but I’m not sure why you want aux 5 to arm.
I have a 6 channel dx6i, and I have channel 1-4 and aux 1 and aux 2.
No aux 5.
Wouldn’t aux 5 be for channel 9?


#26

I think it has something to do with that being the only channel that moves with his transmitter


#27

try to save with the FC disarmed.
set the arm channel, save there, then save and reboot in config with arm switch disarmed.
a lot of boards im finding will not save settings unless the FC is disarmed.
:wink:


#28

You may be on to something here. Once the ARM indicator is on, the “save” function does not appear to work. Also, the CLI does not do anything either. And, once the ARM indicator is on, the only way I have found to turn it off is to go to the Modes panel and delete the ARM setting.

If I understand it correctly I should be setting the ARM setting on the Modes panel to the channel that is activated by the BIND switch on my transmitter. However, I have not been able to ascertain which channel that is looking at the MONITOR display on the transmitter.


#29

see my reply to tronaton below.


#30

I think you need to turn your radio on first - before plugging into USB so that it’s linked to the flight controller. Go assign your arm action on the modes tab and click save. Then toggle the switch on your radio. This will arm and disarm the board right there on the bench. You should be able to see that action taking place by both the yellow color of the arm slider indicator and by an emblem on top of the configurator screen. Then make sure you toggle to disarm on your radio. Click save again for good measure. Then disconnect USB and reconnect it to see if this change has stuck.


#31

The problem seems to be that none of the switches affect what is received,

Furthermore, I cannot see any thing on the Transmitter’s Monitor screen when the BIND switch is toggled.


#32

I thought you were getting a response on aux 5?


#33

If we back up a step and just arm with stick command … This may be a better solution for you. What is the max value you get with full yaw right on the receiver tab?


#34

I only tried AUX 5 because the I saw Channel 5 mentioned in one of the videos.


#35

You have to move your switches on your radio and look for action on the receiver tab to know what aux channels are active. Let’s abandon that anyway. We know your throttle goes low enough. What is your range on yaw? And does the bar go right with right stick?


#36

The maximum yaw is 1863, but when I move the stick to the left? To the right, the minimum is 1145. I believe that this can be reversed with an option on the transmitter.


#37

Ok. Yes that will need to be reversed in your radio. Also when you roll right - the bar should go right, and when you push pitch up (check me guys - I can’t remember at the moment) the bar should go right. Reverse channels till you get that action and report back the max and min travel on each one.
Side note: this is not going to fix the problem yet… but is just a step working in that direction. I’m not going to hit you with the full procedure at once… just follow along and we’ll get you in the air.


#38

OK, got them reversed.
min max
Roll 1144 1862
Pitch 1144 1862
Yaw 1144 1862
Throttle 1007 1862
AUX2 1146 1862 (Changes along with Throttle).


#39

Great. Now there are two ways to fix this. You have to get 1000 to 2000 with 1500 at center stick.

We are going to try an easy one since we don’t have a lot of familiarity with your transmitter.

But first, are your center stick values all 1500?


#40

On the Receiver panel with the transmitter OFF, I have Roll, Pitch and Yaw = 1500. Throttle is 885 but the stick min value is 1006, stick Center = 1500 and Stick max is 1861. AUX 1 = 1504, AUX 2 = 1307,