Crazybee f4 pro v3.0 toothpick

Hello guys,
i am new to this community.a few days ago i ordered parts to build my own tiny toothpick quad similar to eachine reddevil toothpick.i put everything together,set up betaflight and when I arm the quad and as soon as i move the throttle a little up it flips and disarms.

i have tried these things
1)calibrating accelerometer, it works but the “heading” value keeps increasing and after say 10
minutes the quad has rotated almost 20 degrees by itself.
2)disabling accelerometer no gain.still the same issue
3)check motor rotation no gain still the same issue
4)check props orientation no gain still the same issue
5)flashed different firmwares no gain still the same issue

firstly i thought it was issue with accelerometer but i disabled it and tried to fly in air mode or acro mode which does not use accelerometer and the issue is the same.it flips as soon as i throttle up.

i dont know what to do now.please help me guys if anybody know the solution to this issue.

1 Like

Hi Jerry,
Although you have checked it it sounds like an issue with propellor placement, motor rotation, props in/out setting in betaflight or combination thereof.

  • What is your setting in betaflight ? Normal or reversed prop rotation (configuration tab) ?
  • Check if when manually spinning up the motors in the motors tab the props rotate as per the illustration you saw in the above setting.
  • Please post a pic of your props to doublecheck prop position.

quick edit and addition :

As it is a diy build did you check the board orientation ? Please post a pic of the build and does the quad preview pic in betaflight move along the same axes as the real quad when you move it around ?

It can be a bad accelerometer symptom, i have a tinywhoop with same issue, but it can’t be your main real problem…
As Edwin told, check board rotation, for me it’s the first thing to investigate!
In beta flight, check if in the preview, when you manually move the quadcopter, it rotate and move correctly with your hand!