Channels "jumping" with no input


#1

So I got over the “not arming” thing on my Micro SciSky, thanks to another thread (here):

…but I’m getting the jitters, where my channels will jump up (I haven’t seen them jump down). Here’s a video… any suggestions?


#2

That’s one of the strangest things… Try rebinding around five feet away from your quad in an open area? Just a guess.


#3

Nice, at first blush, it seems better. I just tried it, and had it fall out of the sky, but I wasn’t having those jitters. I’m going to watch closely, but what was your thinking behind the guess?


#4

Should have watched video, figured it was as deadband thing. Yeh never seen anything like that. I would do a complete power cycle and a firmware reflash if it continues. Was anybody using 2.4ghz around you like a cordless home phone?


#5

I’ve got some crazy channel value jumps going on on one of mine, totally different set up though.
Taranis with ac800 frsky rx running at D8. Will be trying to get to the bottom of it tonight. I’ve one other rx the same which I’ve never noticed having this problem. The troublesome one is on a femto fc bl with emax 4in1esc 6A. Could be interference of some sort possibly from the esc in my case. Running betaflight 3.1.1 just now.


#6

I had done a reflash prior to writing this post. Also tried deadbands, but these spikes were way more than a small tolerance of <5% resolution. Did numerous power cycles as well.

I was working on my desk, two big LCD monitors and a bunch of USB, but no wireless… unless it’s my cell phone; that’s always on WIFI, but even that’s on 5GHz. I do have a spare phone on 2.4GHz, so maybe that’s the culprit.

I’m building another quad at the moment, my most deliberate micro build yet, fodder for “Show Us Your Builds”. I’ll be looking in this more, but the thread’s at least raised my awareness of ambient transmissions.


#7

Hi, did you manage to sort this out? I’m having exact same issue on my warlark 80 (scisky)…funny thing is, it happened between power cycles. One minute everything ok, setting up osd with TX and the next - poof - jitters… :frowning:


#8

Ack, I wish I could tell you. At best, I’d say review everything physical, to ensure solid, clean connections through-and-through. This issue was too long ago for me to remember exactly.


#9

Bummer, it’s a new craft, newer flown, just bench flying to set things up…plus, it’s a all in one board, as far as rx …

I guess I’ll try to get a refund from gearbest…