Micro Motor Community

Can you tune around F3 on BetaFlight 3.5?


#1


Just a few days ago, it was raining, and I received a cheap banggood frame in the mail. So, I went through my quadcopter salvage draw to piece together a Frankenstein mini-miniquad. All the parts but the frame are used. Motors are from a year and a half old Blade Torrent and the rear left motor has some vertical play or looseness. It flies pretty good on 3s 350mah packs but on 2s 450mah the rear left side arm dips…here’s a video:


#2

Also, I updated to Betaflight 3.5.2 from 3.2. so I just have default settings and the dip isn’t much better. Then it got rainy again, and now I’m hoping for a silver bullet answer to fix this so I can adjust something once or twice and have it flying better.


#3

Hi Jake,

My blade torrent motors have a very small nut holding the bell to the stator in stead of a c-clip, you can try tightening that. It’s probably best to check the other motors too as those nuts have a tendency to come loose and cause the bell to fly off in a crash. At least that is what happened to me before adding loctite.


#4

I noticed the nut, but no luck there… I actually sheered the shaft off where the threads stop because nut was max tight. I did salvage a bell off a motor I shorted with an excessively lengthy mounting screw. I think I would need to press the shaft up slightly inside the bell to tighten up vertical play, but I don’t want to risk ruining it completely. The weird thing is on 3s I don’t notice a dip and it flies normal. I was thinking something in BF 3.5 could help


#5

You say the problem is bad on 2s and less so on 3s? The pids required for locked in flight are going to be quite different between these 2 battery selections as is the filtering. 3s will likely fly pretty well on defaults, but 2s will need a big increase in P and D. It’s likely that after bumping 2s P gains on roll and pitch to near 75 and D gains up near 40… the problem will be lessened. I would also run I gain near 75 and make sure I term relax is enabled. You may need increased filtering at these gains. Finally lower the antigravity threshold and then start increasing it’s gain to knock back the rest of your problem. So … no silver bullet - more like a whole clip that needs to be fired. Remember you can switch profiles via transmitter so that you also have 3s settings accessible via transmitter too.


#6

Hey, is 36% cpu too high? I’m thinking that’s the reason for the fc to start beeping and stop the motors just as the quad starts to lift off the ground… Also is it a big deal to lower the gyro frequency to 4kHz pid loop qkHz? Cuz that takes the cpu down the 14% and that lets me test hover and punch, (to cold and windy for proper flight) p’s around 75 D’s at uper 30s’ helped dip. I’m using the EMAX AIO F3minitower so BF 3.5 may be too much for it to handle?


#7

I’ve uped the all pids on pitch and roll and enabled I term relax, and that alone fixed about 80% of the issue. I can’t find antigravity threshold, just antigravity mode and antigravity gain…I didn’t notice a difference between 8kHz and 4kHz loops other than my EMAX F3 Magnum mini runs half as much CPU % on 4kHz.
Side note: Betaflight won’t let me change RC smoothing to filter, is that feature to much for a F3 board?


#8

What are the beeps that you get?
Imho, filtering isn’t for an f3, unless you don’t enable anything and keep the CPU down. I’ve that just tuning well is fine for an f3, and extra smooth with filtering on an f4 or f7.


#9

So I don’t know what the beeps I was getting were caused by, I just put it back at 8k & 4k (cpu% now 46ish%) and it flew perfectly normal (on 3s lipo) for a whole pack! It still has the main problem from in the video^ (the nose does not hold steady during sharp throttle movements)… and I changed the thread name because I’m not even sure its caused by a weak motor anymore, I just build a new 3" quad with the same Emax F3 magnum stack and all brand new, un-crashed, 1106 4500kv motors, and it too gets an arm dip when on a less-than-half-full 2s lipo. I’m starting to think my old, week, sub-rated 2s lipos are the problem, but there has to be a way to compensate for that on BetaFlight 3.5.2… Which led me to the new thread title because all my BetaFlight quads are F3 and not all new features are supported on F3 boards. Maybe I’m not understanding how to activate them, like absolute control, I move the slider bar from 0, with i term relax on RPY, and save, but when I come back it’s set on 0 again.:thinking:


#10

Try reflashing the escs. The arm dip could be the escs or its the motor. The nose not holding steady is most likely just tuning. Any time you switch voltages, i.e. cell count, the quad needs to be re-tuned.
What slider are you talking about? Also, I meant the number and duration of the beeps.


#11

In the PID tuning screen, under the PID numbers and rates there’s a section with I term rotation, acrotrainer, throttle boost, and absolute control… In my configurator 1.4 (I think) with Betaflight 3.5.2. there is a slider bar that goes from 0-20 for absolute control. As for the beeping, I’ll listen for duration and quantity if it happens again.