Burt's Fusion Micro 114 build journal -- "The Murdock"


#61

Thanks. I’m in the habit of Rx on first for binding, then Tx ever after.


#62

Found an interesting tidbit in Deviation, where clicking “ENT” on “DSMX” gives two more options: “Telemetry” and “OrangeRx”.

“OrangeRx” is a Yes/No toggle. I tried setting that to “Yes”, but no change in my binding problem.

Here’s some info on that settings… seems a bit picky on when/why it’s beneficial: https://www.deviationtx.com/forum/protocol-development/6789-info-for-the-orangerx-dsmx-protocol-option


#63

The only reason I’m sharing now, even though I’ve intended to in the past, is because I’ve been itching to show how frickin’ cool this frame is. While it’s also helped me to “get in my bones” the difference that KV ratings make in motors, this has been really fun.

I read elsewhere of having hangtime after punches. This gives me that on 2S with the Racerstar 10000KV 1103 motors. But, and the thing I want to make clear with this video, is that I get that while carrying a Mobius Mini; thus the HD vid with OSD inset.

Fitting everything in the body is fun and tidy, and while I have a couple other frames, including the Awesome E90 90mm, I’m of the mind to get a few more of these Fusion Micro 114s, and to try variations on it; it’s been a really fun frame to work with.


#64

I use the r111xn, bound in DSMX mode with my Devos, usually with no problems.

In the model file I specify # channels as 7 (possibly an artifact of starting with the Devo7e )
Protocol DSMX
Fixed ID: none (although seems to work with 123456 also)

on the FC side:
set spektrum_sat_bind=9

That’s usually all I have to do. If you are running the latest nightly (at least the one maintained by vlad_vy, it has a high speed (11ms) DSMX protocol option (I think you need to click enter on the DSMX button to get to the protocol options). I don’t use the OrangeRX option.


#65

Tried all those suggestions, Denovich, still no solid bind after cycling power.

Update on this quad… tuning’s still a challenge for me, and on something this nimble, I think I’m struggling even more. I’ve had to mount smaller props (FuriousFPV 1935-4s) because the other props I’ve been using were too powerful to get a handle on this.

Having mounted the 1935s, it’s much more stable and easy to fly – that’s the frame, I still love it.

I’m investigating further the FC and ESC, as there’s an unreliability to the quad upon startup… sometimes it’ll just act sketchy, other times fine. I haven’t figured out why.

Inconsistencies like this are everything that I want to get a handle on. I hate inconsistencies. I don’t mind widely varied performance, but inconsistencies grate my soul.


#66

Struggling here. I’ve been having weirdness happening, and just finished rewiring things to be clean and solid.

When connected to BetaFlight via USB, things behave well. I can calibrate the ESCs, currently set to MULTISHOT. I can control the motors properly, and the transmitter will arm and control throttle. My AILERON controls are sporadic, though, and hold my stick left or right will register a value, but then the value will revert to centered after a moment.

Worst, though, is that when I connect by battery only, I’m not getting steady power to the ESC. The ESCs will either boot individually, not in sync, and/or they will go through the calibration jingle.

I’ve wired battery direct to the ESC, then wired the LC Filter from the ESC/battery to the FC. I’ve wired the cam lead from the LC Filter output, but I don’t even have the cam connected at this point.

Any ideas? Does this point to a fault in one of my components? I feel pretty good about my wiring, and haven’t had any hard impacts at all with this.


#67

You might want to try DShot to see if the issue still happen


#68

The FC will take the main battery voltage, try powering the fc directly from the battery?


#69

Did you bind with DSMX 2048? Or DSM2/X 1024?
Make the corresponding selection on the Configuration tab.

Also did you set the channel order TAER1234? vs AETR1234. (I think this is on the RX tab)

If your RX isn’t being recognized properly (check the stick inputs on the RX tab) that’s your main problem and what you need to sort out.


#70

@Bluesky, I’ve tried DSHOT600 and MULTISHOT, both supported by ESC… same behavior. I am manually calibrating after switching protocols, but not 100% that’s always necessary. Do you know?

@DsAds, I can try to remove the LC-Power filter, okay. This was working before with the filter, though, so not sure what broke.

Bound with DSMX 2048. The receiver is bound, channel order is correct. Stick inputs are correct, but the AILERON channel is acting sporadically.


#71

I’d try swapping in a different rx first thing in this kind of situation, something is wrong in the path from your tx input to the fc output, the rx is the most likely weak link if all your wiring is 100%. If the behaviour persists with a different rx then look to the tx or fc.
One quick check you could do is set up a new model from scratch on the tx, models sometimes go weird.


#72

Easy stuff to try, thanks.


#73

Has this FC ever worked?
Are you sure you are running the correct firmware?

I’m really having a hard time imagining why just the aileron channel is wonky.

I would go over the board with a magnifying glass looking for anything that didn’t look right. Might find a capacitor that isn’t fully soldered or a stray solder ball or wire flragment.


#74

It has worked, wonderfully as well, but never for long. I’ve had ongoing issues getting the full kit to work, inclusive of a cam.

I’ll tear it down. Thanks for the sanity check.


#75

I had a problem similar to that, and it was low battery.


#76

Thanks. Surprisingly, I had checked that. :slight_smile:

I tore it apart last night, and will do close inspection soon.


#77

Probably checked this too, but same tx same RX on a different FC? Mostly to check the tx/RX.


#78

I believe this is a BIG UPDATE, from a BIG LESSON!!!

The LC-Filter provided with the Eachine Minicube FC v1.0 is NOT a voltage regulator per se; instead, it only “cleans” the power to lessen spikes/dips. The voltage coming in will be the same level as going out, thus connecting a 3S battery to the input will provide 11.4V out, which is WAY MORE THAN A CAMERA CAN TAKE (or much else for that matter).

I hope someone will tell me where I have gotten this wrong, because I can NOT imagine being the ONLY person that is learning this.

I’ve replaced the LC-Filter with a step-down BEC. I’d been recommended Pololus for this mechanism, but had an adjustable BEC available, which seems to have done what I needed. While I was given a report that these BECs do NOT clean power as well as Pololus, I’ve also received reports that they do.

Alas, I have definitely fried the AIO cam that I had wired for this build. The OSD/VTX works, but the cam is hosed. More on that later.

The BEC just barely fit between the FC and ESC, so the build is still super clean IMHO.

Making progress.


#79

Powered up, and NO MAGIC SMOKE!!! Redid a CM275T 4-pin rewiring for BF OSD, and it works!!! Already bound my R111XN, everything’s installed nice-and-tight… feeling pretty good here!

This is in the queue to be maidened… hopefully later today.

Cam wiring for BF OSD

TIdy Insides

Lean – Made the Cut!

Ready to fight crime!


Hooking up OSD to a VM275T?
#80

Hi, I used this guide to hook up my VM275T (same thing) for an OSD and it is flipped horizontally! I severed the pin with an exacto knife (I admire your ability to remove it completely) and I get clear video, but it is mirror left to right. I can’t find a manual ANYWHERE, so is there any chance you can help me out? What can I do to get it back to normal? Thanks!