Blown FET? on Scisky board. Need help ID'ing

Puget Sound solder party? I had no clue I had fellow micro-ers up here.

Kinda random but do either of you have any 4pin jst 1.0 leads to get 5v outta a scisky? Mine got lost on the slow boat from Hong Kong &I wanna test out the new quanum Cam + vtx combo

So can anyone tell me if these will work? http://www.ebay.com/itm/MOSFET-N-CH-20V-6-5A-SOT23-QTY220-sold-together-/201513985770?hash=item2eeb2b66ea:g:OWoAAOSwKtlWq79n

They are 6.5A instead of 6.3. I’m trying to find a place that I can have some shipped locally.

@tehdixie Hey fellow washingtonian! I don’t have what your looking for, but @madman1412 just may.

@tehdixie: just solder a wire with matching connector directly to vin and gnd of the power leads on the scisky. You don’t need 5v. This combo works from 2.5-5v. So your 1s flight battery will do the job.

I am currently looking for new FET. @chrisdo mentioned link to the proper part at digikey in other thread. For me digikey is a bit complicated, because they charge 18€ for shipment, and especially when they use UPS only. European VAT, UPS + customs clearance automatically means that I will be paying for 20 FETs 6,62€ + 18€ shipment + 24% VAT + 18€ UPS handling fee (customs clearance handling fee). Ebay and amazon had some 1-2 chinese options available, not really cheap and long delivery times.

If someone is looking for other than digikey providers for IRLML6244TRPBF FET , I think this gives a good overview about the options available: https://octopart.com/irlml6244trpbf-international+rectifier-18793198.

Many of those sell only full reels (3000), but cut tapes quite often available too. Not all sell directly to consumers, but at least TME does in Europe. And they seemed to be quite cheap. TME did not have picoblades available at all, so I ended up using Elfa Distrelec (which is not actually on that list - but with part number googling is quite easy).

All the above is valid for motor connectors, just use part number WM1731-ND to find the product.

Hope this helps someone.

1 Like


Isn’t too cheap - nevertheless no UPS/VAT extra handling, should ship in the EU quite well. Faster in Germany.

1 Like

Hello everyone, after a long wait I got these FET. According to you compatible? Because the code above is different from the original.

Numero del Modello:
IRLML6244TRPBF IRLML6244TR IRLML6244

Yep they work.

1 Like

Yep! I have just tried and two Scisky were reborn!

7 Likes

Hey @IKKI. So those markings on the FET are actually manufacturer code which allows them to identify date and lots of the manufacturing but does not necessarily identify the part. I see that you already got the answer to whether they work or not :wink:

Now for a little more info on those FETs. These FETs have been notorious for doing what happened with the two on your Scisky. These type of FET the SOT 23 have very poor thermal characteristics from what I have been told and from my personal experience they also have very poor quality control for these. I found this out the hard way with a batch of FETs that were inter mixed with 2 or 3 others and one of the batches was faulty. They did not go nuclear and burn up but rather would spin up the motor about 25% and remain stuck like that. This happened first on some AlienFlight builds and so I assumed maybe it was me but that did not check out because the FC did not have any misplaced components or faulty work. My next assumption was that possibly something wrong with the manufacture of the PCB. I discovered that this was the FETs when I repaired a few AlienWii production run cards with these FETs and they did the same. Funny part, not really funny, is that they worked fine and would not do that if I used the 8mm 15’s only with the dark edition motors.

1 Like

Thanks for the explanation. I was wondering whether to replace these fet with the original nano QX can take advantage.

Problem with those boards I believe is that the traces are underpowered which is why they can’t do 8mm motors. I would guess that the nQX has the IRLML2502 on them and should be interchangeable with the 6244 but I have not done it nor confirmed that is the FET on the nQX but I do have some here and will have a look later.

1 Like

I guess that happened to you this! The first attempt to run the last F1 betaflight at the first crash here is the result. I have already replaced the FET again, hopefully it will be the right time! Ah looks fantastic the last version of betaflight!

@IKKI, that is exactly what was happening to me with some FETs that I had. I ended pulling and replacing them on all these cards that I had used them on. They would only do that with the dark edition motors. After replacing all of them again, I tested them with dark edition motors to be sure that the replacements were good. If you replace that again and it does the same thing that would be a good indication that those FETs you have are faulty.

Unfortunately I’m unlucky. Besides losing the first card for a flyaway. I burned another spare mosfet on the second. Has anyone found a solution to the flyaway? Thank you

ikki try this for mosfet https://octopart.com/irlml6244trpbf-international+rectifier-18793198

1 Like

After the “first” evolution I started losing the signal, I lowered the stick and operated the yaw then I even unarmed … I thought now drops or slams against the tree … Instead Bye Bye…

Where abouts are you @ikki? I can send you some known good FETs that I have here on hand and have tested to be sure they are good. Let me know if I can help.

Awe man as I was posting you put up that video. That is a horrible feeling watching that happen :frowning: I have been very fortunate myself and LOS have only lost a nQX somewhere out in the overgrown field behind me and the one that really hurt was the fully dressed FPV wasp 110mm that lost video while I was flying into that field through the opening in the trees in my back yard. That was a very sad day for me. Always a risk of this happening and I suppose that is the chance we take but when equipment failure is at the root of the issue it is so much more sour when that sort of thing happens. I am typically very determined and if I saw where that went down sort of I would rewatch that video and go look, again and again till I had wasted too much time. I went 3 days searching about a 1/2 hour at a time for a quad that I saw go down through a neighbor’s tree. I knew it was there but both myself and my other neighbor looked and looked but could not find the thing. Chopped down the brush with a machete, my neighbor used a metal detector, nothing! Then I started kicking brush the 3rd day I went over to have a look and there it was, almost exactly where I saw it fall! Story is, don’t give up on that there is always hope.

3 Likes

Thank you very much for your support. But… I’m from Italy. Nice place for other things.

1 Like

Not found?? Man, sorry for your fly away @IKKI couldn’t believe my eyes!

Did you have Failsafe configured? I have mine set to switch to level mode, center sticks, and slowly drop throttle.