Blade Inductrix FPV Pro


#41

Of course it will…thanks for reminding me Chaotix, doh!


#42

Mine came with NAZE 3.1.6 Mar 22 2017.


[Wiki] - micro flight controllers
#43

So after all this chatter, has anyone actually verified if the FPV Pro NAZE board is an F1 or an F3 as advertised…not hearsay, need fact.

I want to take it up to BF 3.2.5, would be nice to know what the board really is.

Cheers


#44

Just look at the writing on the chip. Stm32f1xxxx or stm32f3xxxx.


#45

I have a Microscky V1 (Naze F1) and it works perfectly with BF 3.2.5.


#46

Shows how much I know. Too easy, thanks Chaotix.


#47

Thanks a heap chime13. I’ve been tempted by 3.2.x, but was worried about it not re-connecting after the flash and having to look for boot mode pins, mess with USB drivers and all that stuff. They’re different boards, but that’s good enough for me. :grinning:


#48

Love to know if anyone has got the Inducrix FPV Pro in to bootloader mode. I have followed instructions/diagram as above, but no bananas. Pretty sure i smoked something in the process as now no led’s flash when i connect USB - they do if I connect a battery to the board, but not the USB connection. Could be time for another board - any recommendations for a replacement FC? Someone did link one, but now I can’t find it :disappointed_relieved:


#49

Here ! :stuck_out_tongue_winking_eye:


#50

Thanks tarkux, got that already…followed instructions, but it’s just not working for me, with power during short or power after short. USB power that is. Pretty sure I fried something in the process as no LED’s flash (at all) when I now connect USB - only when I connect battery. Thanks anyway. Cheers. (perhaps I’ll have another go tomorrow)


#51

Have you tried to flash it while pads are shorted and usb plugged in?
With boot pads shorted it’s normal that no lights are flashing.
Read the yellow box (recovery/ lost communication) on Betaflight Firmware flasher tab.


As said I haven’t messed with flashing this damn FC, so shooting out in the blue.

Good FC:
BetaFPV with OSD
or anything with nfe silverware on it (cheap and super flying experience but not that comfortable to set up as BF).


#52

Thanks chrisdo. Have tried every option available. As I said earlier, I obviously shorted something yesterday whilst trying to short boot pin - I didn’t see it, but briefly smelt the smoke. Inserting the USB connector no longer causes LED’s to flash and it’s certainly not in boot mode - i.e they should flash as they were doing. It flashes when a battery is attached, but I have obviously shorted the USB circuit somewhere as it is non responsive. With this scenario being so common (I’ve resolved it before this way on my 5" QQ190 no problem), you’d think a button or 2 close boot pads would be the least they could design into their board. The betacube board won’t fit the Inductrix frame (don’t want to build), so considering a BeeBrain V2 stack. Might even buy the AcroBee v2 and be done with it. Thanks for your support. Cheers.