Micro Motor Community

Binding a Silverized/NFE E011 to a QX7 using an IRX4+ [Solved]


#61

Ok - using DevoArming.hex Arming/idle up on Channel 10 linked to SF (bottom left)
Rest of the switches not doing squat - haha


#62

Ok so ch 5 and ch 10 are crossed between devo and multi selections. That would seem to indicate a multi mapping for your transmitter module. I would think then if you flashed tge Multi Arming hex that you should be arming on channel 5 instead of 10 in your tx like with the devo hex. As for the other switches not working, channel 6 is the same in both maps. Focus on that one. I’m gonna say at this point that it’s no longer an issue with silverware … it’s in your transmitter setup. Find a channel output monitor … see what your switches are actually doing.


#63

Ok, MultiArm.hex does not work with my setup.
Going back to explore DEVO

Works great - exploring switches

DevoNoArm = Toggles Acro on CH5


#64

Yeah. That’s strange. The only difference is channel 5 and 10 are swapped. The rest of your issues have to be in transmitter setup. Unfortunately I can’t help you there. I have no knowledge of your setup. If i had to guess, I’d say it is an endpoints issue. Does open tx have a channel output monitor? Are your switches even toggling an output signal?


#65

This is how it works with your DevoArm.Hex

So to surmise:

To use a QX7 with an IRX4+ to fly Silverized/NFE FW on an E011
Flash quad with DevoArm.hex

QX7 internal RX = OFF
External RX = MULTI BANGYANG
Protocol = BANGYANG with Telemetry
Ch1 = AIL
Ch2 = THR
Ch3 = ELE
Ch4 = RUD

For the Auxes to work you must do the following:
Menu 5/11
Long press on selected channel will give you EDIT
Source = Switch
Switch = Switch State (Always Down Arrow)

I set mine up like this:

Ch6 = SA = Level/Acro
Ch7 = SB = Racemode angle (Ch6 must be ON)
Ch8 = SC = Not sure
Ch9 = SD = Some Crazy Level mode (Ch6 must be ON)
CH10 = SF = Arm/idleUp

This is what I got so far. I’m not sure about getting anything else ATM.
Racemode is wild BTW takes some getting used to.
Crash recovery (bouncing off things) is way far superior than anything I’ve flown in BF. It doesn’t seem to get as confused as its BF cousins of identical hardware.
LVC Blink LEDS = very cool
ACRO mode = Sweet but I have to remove some expo
Level modes = very useful but doesn’t quite feel right for me
I hate having to rebind every time though…no biggy

I do like this combo


#66

I’m still confused as to why you can’t get idle up to work. You’re missing airmode without it. Have you tried compiling and flashing from the file I sent you in keil? Maybe assign arm/idle up to channel 6 and acro/level to something else. Move your channel numbers around in software.


#67

I’ll compile it from the Boldclash zip you emailed me. Otherwise LOS is rock solid even without a camera


#68

Cool. Try moving those channel numbers around before you compile. Swap 5 and 6


#69

Ch5 =
Ch6 = SA = Level/Acro
Ch7 = SB = Racemode angle (Ch5 must be ON)
Ch8 = SC = Not sure
Ch9 = SD = Some Crazy Level mode (Ch5 must be ON)
CH10 = SF = Arm/idleUp

My Brain Hurts


#70

So that looks like everything is working except something is crossed in your outputs between 5 and 6? Maybe that’s why it wouldn’t arm on 5. Whatever it is doing in your tx should be visible in an output monitor (I’d hope). Anyway great work … looks like you made it to something flyable.


#71

Hello everyone I hope all is well. I made a video on binding the Beta65s Lite with the MTX-X9D Multiprotocol Module. I hope this helps anyone with issues.


#72

@chime13 your page 5 of 11. What page name is that? I have Taranis.


#73

Here are all the pages available under the Model Menu

Taranis QX7
1/11 Model Select
2/11 Setup
3/11 Flight Modes
4/11 Inputs
5/11 Mixer
6/11 Outputs
7/11 Curves
8/11 Logical Switches
9/11 Special Functions
10/11 Telemetry
11/11 Display


#74

Thanks Bro…can you list how you set up your inputs page?..


#75

Ch1 AIL
Ch2 ELE
Ch3 THR
Ch4 RUD


#76

sorry…your aux’s…im not getting all my modes…trying to decipher and compare to yours since you are the only other person i know using Taranis and irange 4in1


#77

and were you able to get telemetry…i dont recall nad if so, how?


#78

That’s all I have on the INPUTS page.
The AUXes are defined in the OUTPUTS page.

Telemetry Menu - Discover sensors.


#79

ah…hmm…was always in the understanding that inputs had to be defined as as well as mixer?

on telemetry…i tried to discover sensors and it did nothing?


#80

Don’t know - with my setup I got it all by not using PPM. I youtubed the setup procedure and basically this is all you have to do. @Bobnova was the one that gave me the correct setup regarding my configuration. (Rotary Dial on back of XR4i stays on 0) Bind and setup through TX menu 2/11