Micro Motor Community

Binding a Silverized/NFE E011 to a QX7 using an IRX4+ [Solved]


#1

Slowly getting there but since I have no prior experience with the E011, I don’t know what I’m doing incorrectly.

When I power on the FC, it blinks slowly until I turn on the QX7 in Autobind mode, then it blinks fast but never goes to solid. I do have AETR setup and using BAYANG protocol.

According to everything I read out there, after the fast blinking, I should move the throttle up and down and the lights should turn solid. Never does.

I did try it with 2 different E011 FCs and got duplicate results.

Anyone?

UPDATE: In order to save you a lot of scrolling, I cut and paste my post that describes how to do it:

To use a QX7 with an IRX4+ to fly Silverized/NFE FW on an E011
Flash quad with DevoArm.hex

QX7 internal RX = OFF
External RX = MULTI BANGYANG
Protocol = BANGYANG with Telemetry
Ch1 = AIL
Ch2 = THR
Ch3 = ELE
Ch4 = RUD

For the Auxes to work you must do the following:
Menu 5/11
Long press on selected channel will give you EDIT
Source = Switch
Switch = Switch State (Always Down Arrow)

I set mine up like this:

Ch6 = SA = Level/Acro
Ch7 = SB = Racemode angle (Ch6 must be ON)
Ch8 = SC = Rate Profile
Ch9 = SD = Some Crazy Level mode (Ch6 must be ON)
CH10 = SF = Arm/idleUp

This is what I got so far. I’m not sure about getting anything else ATM.
HTH


#2

Sounds like these are already flashed with silverware? Slow blink is the gyro calibration, fast blink is waiting for bind. No idea on the module. If they’re flashed you shouldn’t need to do any throttle stuff. That was an e010 thing anyway. Not e011


#3

AFAIK these FCs were stock that I bought from BG. I bought 4 of them. 1 has a missing motor plug but that’s about it.
I thought maybe I’d have to arm it or disable some failsafe in order for the lights to go solid and the motors to spin.


#4

I’ve honestly never bound a stock one. Lol. Well I’ll be watching attentively and useless to help again.


#5

Ok, so do you think flashing it with your BHWoop might change things around? If so, what’s your latest build?


#6

I successfully flashed it with bwhoop.hex and tried the pro one too but all that changes are the blinking speed of the LEDs. Don’t know what else to do. Really frustrating


#7

If it’s an e011 and you flashed bwhoop, it should be blinking 4 times (I think 4 times) in a repeating pattern. That indicates a missing radio module because the bwhoop radio pins are different than the e011. My latest version is on my github page. You will need to compile it in keil before flashing. If you’re not up to speed with that yet … go to silver13’s github and get a stock silverware hex for the e011. Flash that. You should get a pulsing dim led during gyro calibration then rapid blinking as it waits for bind. The issue with binding is in knowing the right procedure for your specific module. @CRayTech also just contacted me with a struggle to bind to the beta fpv lite flight controller. Unfortunately I don’t know anything but a devo. Don’t get frustrated, just stand by till someone with a similar multimodule can chime in! We will have the answer soon on what procedure to follow for binding to an e011.


#8

THANK YOU!!! Yes - flashing stock silverware hex for the e011 gave me solid lights and runaway motors that more or less respond to the sticks.
Tired - going to bed.
Try it some more tomorrow.


#9

Unless I can get some concrete info, I’m basically done.
I can’t figure this thing out. E011 stock FW definitely doesn’t work unless I flash it with Silver E011 FW but then:
1 - I plug the bat on the FC
2 - Turn on QX7 and move the throttle until the lights turn solid
3 - motors go crazy and can only quiet them down by moving the ELEV and/or some combo of sticks - If I let them go, the motors spin up again.

I honestly can’t tell what channel is doing what, so I can’t flip the channels around.
Gestures/stick commands don’t seem to do anything.

I can’t believe that I’m the only one in the world that has this particular combo and yet, can’t get anywhere.


#10

Settle down. Lol. Let’s start with an accelerometer calibration. Get bound up to a solid light and then do pitch down 3 times with the throttle off. You should get some blinking to indicate the calibration happened. Try that and report back!


#11

I know I know…hehehe

On a whim, I swapped the THR and ELE channels on my TX and everything good so far. Doing gestures I could see that something was happening because the lights would flash a few times then return to solid. With FC connected to battery and all 4 motors splayed out on the table, it seems ok as far as response. I’m gonna put it now on one of your lovely little v1 Boss editions and see how it works.

Last thing (for now) I normally like to run Props reversed (spinning away from camera lens)
How would you go about doing this or do I need to run them conventionally unless I recompile some file, I suppose.


#12

I’ll pay shipping for them when you fail

Just kidding. Listen to @NotFastEnuf, he is one of the best sources of info on the whole world wide web.

I have heard nothing but good things about NFEs FW so once you get it, you should be good. Keep at it


#13

Yes I know, he’s the Yoda Of Tune! - Hahaha
Seriously, yes - NFE has contributed an S-load of time, knowledge and plastic to the cause - I definitely appreciate his contributions and insight.


#14

Yeah that stock silverware file you flashed is conventional props and a really soft tune and soft rates for a whoop. It will struggle with a boss. You’re doing great so far… it’s all about learning new equipment. Sounds like you’re ready for a test hover. Get that under your belt just to confirm you have it all sorted out and report back. Maybe just shove it all back in the whoop frame for that test.

The next step will be using Kiel to compile the hex. We may need to overcome some of those gcc mac issues. But we will stick with it. Once you can compile with keil… we can use my silverware fork to load a boss tune, set props out and reversed motors, and then put your boss together!


#15

Success!
Using the Stock Silverware for E011, I was able to calibrate the ACC and also toggle ACRO/LEVEL modes. The little guy (sans camera or final config) flies amazing - so responsive in ACRO mode. It’s got a lot of shakes and quivers, again because things are not properly mounted, but I’m so impressed so far by the potential. ATM, it feels even better than my Scisky v1 BF 3.2.5 build - hahaha

If there is one thing I don’t like is having to turn off the TX every time I change the battery on the quad in order for it to bind again to the TX

Ok - What’s next? I got all of the required apps and hardware, and they are all working really nicely in a Windows 8.1 VirtualBox. giddy giddy giddy


#16

I guess next go to my github page and download the zip file for silverware. Read my readme file too - it will help explain what we’re about to do… Unzip the download and open the uVision5 project file. It should launch keil. Once there navigate the src directory to get the config.H file open. That is where we do setup. Take not of any error messages that show up getting to that point.


#17

I couldn’t find the project file per se but I did find both config.h and pid.c.
Opening them up in the editor I updated both files to reflect my preferences. (saved to a separate folder)
THat’s as far as I am able to get now. I don’t understand forks and how to merge/compile my newly modified files.
Next!


#18

Have you installed the keil in your system yet?


#19

Is there a e011 joke about keil chips yet?


#20

Yes - I got Keil and updated all the packs so far except for keil:STM32F0xx_DFP:2.2.0 which it keeps asking for but doesn’t seem to update.

I did find 2 project files under the Silverware folder (silverware and aero_only) and when I click on either, I’ll get the file message update from above. But, it seemed to load.