Micro Motor Community

Betafpv f4 bushed tiny whoop


#1

I have a betafpv f4 brushed whoop… it flew weakly, so i got 25000kv motors… plugged them in and tried to fly… i thought all was set good but the thrust was reversed… so i swapped props to fly up (instead of down)
3 motors armed fine the 4th wouldn’t spin up unless i moved the drone… but than it would shut the motors off… the motors would also shut off if i tried to throttle up. So i thought it was too much motor for batteries but they where all HV and had plenty of juice. So i put old motors on but the problem remained.
Any help?


#2

Can you send a picture of your betaflight settings please?


#3

Try swapping out the possibly broken motor with the others, to see if it’s the motor or the board.


#4

I don’t have the settings pictures at the moment but it flew fine. And i tried swapping out motors back to the good ones with lower KV but the no longer good. Its as if the high KV motors damaged by board.


#5

Huh… whenever my motors do that, it’s the motor itself that seized up, and it has the same symptoms of what you described… if all else fails always reflashing is good, as well as raising the minimum while idle setting… other than that I have no idea, sorry!


#6

thnx anyway… I think a return and replace should fix it :smiley: