BetaFPV F3 FC will not Arm in BetaFlight


#1

I purchased a BetaFPV F3 DSM https://micro-motor-warehouse.com/collections/flight-controllers-1/products/betafpv-fc-f3 from Micro Motor Warehouse recently. I bound it to my Spektrum DX7 Tx in DSM2 mode as Benedikt suggested. Then I connected the FC to BetaFlight, installed the proper F3 firmware and adjusted all of the stick travels to within the proper limits. I assigned stick A on my DX7 for arming on AUX1 and switch B to change flight modes on AUX2 adjusting the travels for each to the proper ranges in BetaFlight. All of the stick movements show to be within the proper ranges and switch B for changing works and will change from Angle to Horizon to Heads Free without any problem, however switch A will not Arm the FC.

Any suggestions would be greatly appreciated.


#2

Any ideas here please guys as I have exhausted anything that I can think of with @Hammer over the past week or so ?

@Benedikt help :slight_smile:


#3

Plug your FC into Betaflight go into cli and type : Status and give us the Error , Ignore MSP / CLI


#4

Same here, but if I disconnect from BF and plug in a lipo arming works just fine. Try that @Hammer.
Haven’t investigated why it isn’t arming while connected to BF, but anyway as long as it flies ;-).
Btw. I’m on BF 3.4.0


#5

Thanks for responding @pedro147, @tarkux and @chrisdo. When I type status in CLI this is the message I get. If I plug a LiPo into the FC, it still will not arm.

27%20AM


#6

Hmmh?
This is how mine looks.
Bound to my DX6 in dsmx. Looks pretty similar to yours.
No clue why yours isnt´t arming with lipo power.
betafpv%20dsmx

" MSP connection is active, probably via Betaflight Configurator" --> “Terminate the Betaflight Configurator connection (disconnect).”


#7

Two common reasons for not arming:

  • accelerometer not calibrated
  • board not level

Both can be related, because when the acc is miscalibrated, the board thinks it’s not level and won’t arm. Also, the sensor orientation might be set wrong, so it thinks it’s upside down.

The first thing I suggest you do: calibrate gyro and acc via stick command, then try to arm.

  • step 1: full throttle, yaw left, pitch back
  • step 2: zero throttle, yaw left, pitch back
    The FC should respond with a few flashes to each command. If it doesn’t, stick travel might be insufficient. Min_check or max_check need to be exceeded on al, three channels for stick commands to execute.

If that doesn’t work, please post the result of „dump“ (via the CLI) and a picture of your build!


#8

Thanks for responding @Benedikt.

First of all I calibrated the acc in BetaFlight when I first connected. I checked the stick travels and they all exceed what is required in BF.

I then followed your instructions regarding calibrating the gyro and acc with no response from the FC.

Here’s the results of dump in BF CLI and a picture of my build to this point

.BTFL_cli_20180602_165800.txt (13.6 KB)


#9

Ah, I see. You have mounted the FC upside-down, but you didnt flip the sensor orientation.
You also did not re-allocate the motor resources, so even if you would get it to arm, it would just flip over.

You need to enter the following 6 lines into your CLI and hit enter:

resource MOTOR 1 B08
resource MOTOR 2 B09
resource MOTOR 3 A06
resource MOTOR 4 A07
set align_board_roll = 180
save

Let us know how that goes :wink:


#10

So glad that you came in on the conversation @Benedikt and that will be it for sure :slight_smile:

I have been helping @Hammer via email for the past week or so but I didn’t even think of that as a possibility seeing as Alien’s are usually always mounted with the forward arrow on top.

Nice work QuadFather


#11

Hey Peter, thanks for your volunteer work to support my customers, and for pressing my button!

Hope you are enjoying some winter sun :wink:


#12

First of all, many thanks to everyone for their help, I want to especially thank @pedro147 and @Benedikt. Thank you for saving me from my ignorance. :blush:

I’ve decided to turn the FC over so it’s oriented as intended. I connected to BetaFlight, recalibrated the accelerometer and then entered the six lines in the CLI that @Benedikt suggested above. I then reread @Benedikt’s post and realized that re-allocating the motor resources was for when the FC was upside down, so I need to know what to enter in CLI for motor resources with the FC as intended.

Unfortunately, the FC still will not arm. Again, I can use the switch I assigned on the DX7 TX to change flight modes without any problems. The switch I assigned for arming changes values in BetaFlight when flipped but the FC will not arm.

A current picture of the build.


#13

you are most welcome :wink:

To run it right-side up, you need to plug the original values back in (which you could get from your original dump, or be resetting the FC).

resource MOTOR 1 A06
resource MOTOR 2 A07
resource MOTOR 3 B08
resource MOTOR 4 B09
set align_board_roll = 0
save

Good luck!


#14

Thanks very much @Benedikt, I changed the values for the motor resources back to the original in CLI.

Unfortunately the FC still won’t arm, any other suggestions?


#15

Hmm… I see your motor plugs dangling… You plugged them in, right?

Now since your sensor configuration is correct (I think), you should do the acc and gyro calibration with stick commands, as described above. See if the LED blinks in response, and if it arms afterwards.

If not, I will give you a complete setting dump to configure the FC from scratch, just in case other settings have been missed.


#16

Thank you, thank you, thank you @Benedikt! I calibrated the gyro and acc using stick commands and the FC now arms and I can fly. The interesting thing is it doesn’t show arming in BetaFlight but with a LiPo plugged in it arms without problems.

One thing thought, when I’m in the air the red LED on the top of the FC slowly flashes, does that indicate a low battery? I’ll charge some fresh LiPo’s and see how that goes.

Now to mount a camera so I can practice my FPV piloting skills…I really need the practice. :wink:

Thanks again for everyone’s help but especially @Benedikt and @pedro147 I really appreciate the time you’ve spent helping me resolve this problem. :grinning:


#17

Always glad to help when I can @Hammer and I hope this good luck translates to the Pedr :alien: Whoop FC of yours that is currentlyenroute to sunny CA :slight_smile:


#18

Sorry @Benedikt I missed this. Anytime :grinning:


#19

BF 3.3.2 has anti taz saftey that won’t allow arming when connected to bf. You can still run the motors in the motor tab though.


#20

This.
It’s a new safety measure… I believe you should be able to arm normally after you check that checkbox in the motor tab.

Also; setting ‘small_angle = 180’ should allow you to arm whenever you’re stuck upside down in a tree somewhere :wink:
Can be pretty useful sometimes!!