Micro Motor Community

BetaFlight 3.2 FINAL - on BetaFPV F3 OSD Whoop


#21

Ah now I understand. Yes, the RSSI value you can display in the OSD seems to have no input value either.
Although initially disappointing, the lack of RSSI or telemetry in general didnt bother me much yet, because the range of the receivers brings me so comfortably to the edge of my video reception that I consider installing some directional antennas.

I dont understand the arming angle issue. Can you describe when and where you are seeing that?


#22

Ah - here we go. @Benedikt Thanks again for sharing this. Well - i try to live without RSSI on a whoop size. Winter now here and the house i live in is too small to have radio link issues. As you say it - video is breaking up way earlier.

So, firstly i was having arming issues 'till i figured out it was arming angle (OSD warning saying “angle”).
Thus tried to turn off angle checking by entering value of 180 into text box “Maximum ARM Angle”, section “Arming” in BetaFlight page “configuration”.
After hitting “save & reboot” going back to configuration-page did show an empty “Maximum ARM Angle” text-box and arming did not work, again got angle warning.
Could only work around by using CLI command “small_angle”.


#23

I prefer to set values over the CLI rather then GUI. This might be a bug in the configurator.
Also, you might have not calibrated the sensors. IIRC thats causing this error message too.


#24

Can’t recall exactly - absolutely possible. Got mad to soon and just hit “reflash” instead of going into the problem at first.

Beginner here - but i’ll try to advance. :wink: Grew up with DOS 5.0 anyway :slight_smile:


#25

Whenever I have arming issue, I do the double calibration stick trick, goes like this:

  • full throttle, yaw left, pitch down (calibrate acc)
  • zero throttle, yaw left, pitch down (calibrate gyro)
    Make sure the quad is level when you do that. LED should blink to acknowledge command.

When you fly angle mode, you can use trim acc (full throttle, and then pitch/roll to issue corrections) to fine tune the acc calibration.

Easy going then :wink:
Here is the entry to the rabbit hole:
type “dump” to get all settings
type “diff” to get only the settings that differ from default
Just copy any of the lines you get, change the value, and paste it back in.
Dont forget to type “save” after every change you issue over the CLI.


#26

Aye, capt’n, acknowledged and marked on the briefly printed out “stick functions” paper.

… diff, save already in use - just not this time… was too much in a hurry to fly a whoop WITH god damn freakin OSD!


#27

this happens to me too…i think it’s a bug in the Configurator…enter “set_small_angle” in CLI and it works, but still is blank in the UI.


#28

Yup, @PJC, exactly. CLI works , GUI doesn’t accept or show any value…


#29

I was struggling with the first setup of the BetaFPV (OSD) V1.1 board. Updated to BF3.2.2 without problems.

Applying

set align_board_roll = 180
#remap motor outputs
resource MOTOR 3 A06
resource MOTOR 4 A07
resource MOTOR 1 B08
resource MOTOR 2 B09’

lets the quad flip like crazy. Also if you spin up the single motors left and right motors are mixed up.

I checked the marking on the board:

It looks like that normal mounting position of this board is upside down already!
So, I used the factory values:

set align_board_roll = 0
#remap motor outputs
resource MOTOR 1 A06
resource MOTOR 2 A07
resource MOTOR 3 B08
resource MOTOR 4 B09

calibrated gyro and acc and the woop flies perfectly.
Can anybody confirm?


#30

Yes, you only need the quoted lines when you mount the FC with plugs facing up.
The default orientation is plugs facing down.


#31

Im having issues with my OSD on the BetaFPV board @ both 3.2 and 3.2.2 when disarming. The stats just flash quickly and disapears?
Like i would use throttle och pitch at the same moment it shows up…
Anyone else with this problem?


#32

Never seen that before, and I have flown almost a hundred of these boards.
I’d say reflash first, but since it happens on different versions, you have done that.
Have you flashed my above settings or did you configure it yourself?
Are you using the OSD on/off on a switch?


#33

I have used the default settings from the board BetaFPV came with when flashing BF 3.2/3.2.2. Then configured it on my own since I dont want the USB and plugs facing up.

No there is no OSD on/off switch.

Maybe i should try your config and leave out the resource mapping and board rotation. :thinking:


#34

Flashing and applying known-good settings is always a good move if strange things are happening.
What you also could do is enter “diff” into the CLI and post the results here.
Maybe we find some odd setting you got in there.


#35

hey guys I just flashed this latest version and did the dump, but now I cant get my rambo to bind when I plug in a battery the motors just start to spin and I cant get any response from my Qx7 can anyone give me some ideas to fix?


#36

After changing too ppm I’m gettin stick inputs from my QX7 under reciever tab now but she still just spins the motors constantly even when I’m not arming it? so confused. Ive know reflashed to 3.2 stable with all stock settings and still when i plug in battery motors just spin without arming.


#37

You should use the dump from Benedikt and add to CLI.


#38

That is the exact thing i did after flashing. That is what started all this i cant figure out any way to fix. This was bought pre-built by him 7x16mm rambo flys great read this article on updating to 3.2.2 and now this is what I’m getting I’ve never ran into problems like this before and Im pretty new at the whole betaflight set up stuff, thats why I just followed what he said.


#39

Sorry i didnt read close enough :blush:
Try changing “set sbus_inversion = off” and save or change off to on and try. That helped me once, dont know why lol…


#40

Gave It a try both off and on. No change just immediate spinning of motors once I plug in battery, thanks for trying tho :slightly_frowning_face: