Micro Motor Community

Beta 65X: throttle won't respond, but AER all work, what's up? Not my drone!


#1

Hello MM Community,

I purchased a Beta 65X and Jumper plus radio from MMW. I downloaded Benedikt’s transmitter settings and configuration file and uploaded the settings and configurations. I can see in BF on the receiver tab that all channels respond normally. Now here is the strange part…when I bind and arm to fly the throttle (Channel 1) doesn’t spin the motors, however, the AER channels all work. So, I can spin in both directions, I can lift back to front and side to side, but it won’t take off! Anyone ever seen this issue? See the video here:

At Francisco and Benedikt’s suggestion, I have re-flashed firmware (full chip erase) using the latest stable version. Same issues present. Anyone seen this before? Also, I can fly my Blade nano qx with the Jumper Plus so I know the radio works normally with other drones. Thanks, MM Community!


#2

Sounds like arm mode is not activating. That is typically on a switch on the Tx but it can also be done by stick. Try putting throttle at zero and full right and see if the quad arms. Typically a light activated on the flight card to indicate that it is armed. If that doesn’t arm the quad it could be that you are outside the min throttle setting either in BF or the Tx. When you look at channels in BF and the Tx is connected to the FC you should see 1000 min and 2000 max. If the channels are not in those ranges then they need to be adjusted in the Tx menu to output those minimum and max outputs. I doubt that your min throttle setting is the issue since the files Benedikt is using should already be set up properly.


#3

I pointed Dew to post here, because I dont understand whats happening…
The motors are spinning, so it is arming.
Hoping for someone to point out what we are missing here :wink:


#4

There could be a channel over riding the throttle when armed. Plug into Betaflight, receiver tab and make sure throttle moves with all aux switches in all positions.


#5

I have toggled all of them to test, but have not done it systematically like you suggest using BF. I will try that later this evening. Thanks for the suggestion.


#6

Did this test in BF and all switch positions still had throttle receiving input on the receiver tab.


#7

That is weird. Sorry I didn’t see the video first reply and I don’t have a jumper radio. Have you tried restoring the radio to defaults and uploading a fresh copy of the model file again? That’s all I can think to try if you haven’t.


#8

Thanks madman1412! I don’t know what “restyling” means. I have uploaded fresh files a few times. I may be making some progress, though, because after re-flashing firmware again and reloading the configuration files I actually got the throttle to work! Now, though, when I hit the arming switch, the motors are on even when stick is all the way down (i.e., no input). I recalibrated sticks, but I’m waiting for batteries to charge…


#9

Ahhh, that may be airmode if it’s turned on. The motors will always spin if that’s checked in configurator. It keeps motors from stalling during flight but if you crash and props are stuck you want to practice disarm so motors do not get damaged from trying to spin while being stuck. I meant to say restore above.


#10

You did say restore! Thanks for the input. Much appreciated.


#11

And airmode is not on, so I do need to figure out why they run without input!


#12

I edited after you pointed that out :wink: no problem. Hope it works out. If not please post details and hopefully we can get it sorted but it sounds like you are on your way.


#13

Well, what I thought was progress wasn’t sustained success. After battery recharge the little beast does exactly what it did before. No throttle. But AER all work. So, I’m having fun spinning this 65X on my kitchen table! Off to bed, maybe someone has an idea…this makes no sense!


#14

Just re-read the thread, I thought you did not have throttle input in the betaflight receiver tab but one of the replies above state you do.

Judging from the motors that spin and their direction (pushing down) I think you are in turtle mode.

Looking at the config files in the dropbox the switches are assigned as follows :

aux 0 0 0 1700 2100 0 0 AUX1 - arm - switch SWD
aux 1 1 3 1300 1700 0 0 AUX4 - angle - switch SWA
aux 2 2 3 1700 2100 0 0 AUX4 - horizon - switch SWA
aux 3 28 2 1375 2100 0 0 AUX3 - airmode - switch SWC
aux 4 35 1 1400 2100 0 0 AUX2 - turtle - switch SWB

from the video it looks all 4 switches on the tx are on, if you turn off all switches and then only turn on switch SWD it should arm and not be in turtle mode any longer


#17

Thanks for the suggestion, Edwin. I do see throttle response in BF, actually. And with Benedikt’s model set up file, the radio displays stick inputs and I can see that throttle channel is responding when I use it.


#18

Did you check for turtle model, like Edwin suggested?

On the BetaFlight Modes page, does it show that little yellow mark inside or outside the range for the “Flip Over After Crash” mode when your receiver is connected?


#19

If you just push all switches away from you and only pull the d switch towards you to arm it you should be good.

Alternatively you can check the fpv feed, when in turtle mode it should show on the screen.


#20

I will check that this evening for sure. Thanks for reiterating Edwin’s suggestion. I’ll let you know.


#21

Cool. I will try this later tonight. Thanks, Edwin.


#22

If none of this works…please check the motors individually in Betaflight to make sure each expected motor is spinning up in the motors tab. At worst you might have to remap motors, but this situation is often simply the wrong props are on the wrong motors so please double-check that!