Micro Motor Community

Beta 65x help


#1

So I just got my 65x and i can’t figure out how to bind… everything i find keeps showing a bind button but this board doesn’t have one… Is it all done in beta flight?


#2

Your model has an external Rx, right?
The bind button is on the receiver.
Post a picture of the underside if you are still unsure!


#3

Correct so I found the bind button but can’t tell if in bind mode… how do I know if it is trying to bind


#4

Had to hold down then apply power


#5

A new battle now begins… beta flight failed to open serial port


#6

If you’re using a windows pc they often have issues with drivers. Rebooting the PC sometimes will fix the driver issue. Be sure that the USB cable you have is good and works for data and not just charging. I typically plug in my FC first then open BetaFlight.


#7

If you still can’t get the FCC to connect because of the driver, try downloading impulserc driver fixer. That will almost certainly fix it.


#8

Already tried the immersion rc driver fixer and to failed to open serial port… my old v2 beebrain connects no issue


#9

So I reinstalled the drivers and restarted… was able to connect, I wanted to have my switch set up the same… so I disconnected and connected my beebrain and when I tried to reconnect the 65x failed to open port again… not sure what’s going on anyone have a similar experience before


#10

So I’m connected right now however trying to set modes but betaflight isn’t recognizing any of my switch movements… arrhh so frustrated right now


#11

Every time I disconnect, it fails to open port on next connection… so far I’ve had luck reinstalling drivers and starting new… what’s going on? Also I can see my stick inputs but not switches so I can’t arm or change modes


#12

Do I need to do frsky cli dump?


#13

A CLI dump certainly will help. If you are using the same model setup on the Taranis as the Beebrain and you have switches setup already in the radio it most likely means that something is not setup correctly in BF. Be sure that all channels are corresponding to correct stick movements in BF under the Tx tab. If they are mixed up you may need to change the channel order or the Rx settings on the configuration page.


#14

Thanx, so once again BF wont let me connect, I just don’t get it…


#15

As I mentioned Windows machines have issues with drivers. I often have this issue. One thing that I have found is if BetaFlight is already open when the FC is plugged in it will sometimes not show up in the com port box. I have also had FC that looked like they didn’t connect to BF only to find that when I click the com port box that another com port was there and selecting that port got it to connect. Have you looked into device manager and USB devices to see if it is connecting to the pc and just not BF? A final suggestion would be to put the FC into boot mode and reflash the firmware to the latest release. If you do not get it to go into DFU mode that is where you can use impulserc driver fixer. Another note is plug in the card tonthe usb cable first then plug the cable into the USB port. Reason for that is if the card connects and disconnects and connects again it can mess with the pc recognizing the device.


#16

Last update… reinstalled drivers rebooted the machine BF let me connect, got my mode and arm switches assigned… now I can fly yeah thanx for the help… it seems I’m gonna have this issue every time I try to connect


#17

Glad you got that sorted out. One thing is if you get it setup how you like it, you really won’t need to plug it in much. I can’t specifically pin point why windows seems to be the most difficult to deal with, specifically with connecting to FC and the drivers but not always. The other things I mentioned I have found can also cause an issue like opening BF before plugging in the FC, and getting a quick connect and disconnect when plugging it into the pc.


#18

Any advice on OS or is mac the way to go? Just wondering so if I get a new laptop I wont have this issue


#19

The issues seem to be worse with the older windows machines that were running windows 7 or later and got the free upgrade to windows 10. The two pc I have were both windows 7 and have had issues ever since that W10 free upgrade, not just with connecting BF but other issues as well.I have heard from others that have newer machines that have only had windows 10 installed on them that they are not as troublesome but have no personal experience with that. I also have never used MAC for any of this, but I never hear any MAC users complaining about drivers and stuff not working either.


#20

So I just downloaded the speedy bee configurator for android no connection issues no drivers needed, just straight plug and play… I also discovered that you can access BF thru the OSD to change settings and tune PIDs… still trying to figure out this windows 10 issue