Micro Motor Community

Beecore v2 can't connect to Betaflight


#1

I’m using Betaflight on Mac. Two weeks ago, I was able to connect my Beecore to Betaflight configurator just by opening Betaflight and plugging in the usb. But now it doesn’t connect anymore even when I clicked “Connect” and “auto connect”. I have no other Betaflight fc to test.


#2

Huh. Have you had a crash recently? That exact thing happend to me when I crashed, check under device manager if it shows up under USB. if it doesn’t we have the same symptoms. I’m still figuring it out. Is it a whoop or a full sized? My problem is on a full sized. If it shows up try to flash it, Even if you have to do it hundreds of times. It might work.


#3

Just to cover the obvious… have you tried another usb cable and/or port?


#4

I have two data cables and both of them worked two weeks ago, but now I tried both and still the fc can’t connect to Betaflight.


#5

It’s a 7x16 whoop. I never crashed it yet, I just hovered it and landed very smoothly on my bed.


#6

Hmm. Do you have a Windows PC? Some chrome apps don’t run stable in Mac os. Is there a device manager on Mac by any chance?


#7

Exactly :wink: drivers if it’s Windows original poster said Mac but if you are using a windows machine @FPV_Lover could be drivers. Try using impulse driver fixer in that case, only works for F3 FC. You can find it here if that’s the case https://impulserc.com/pages/downloads
Mac just works so they’ve never made a driver fixer.


#8

I have a pc but I don’t have it this day. Maybe tonight I’ll try to install Betaflight configurator, Drivers, and driver fixer for pc.


#9

I don’t know if theres a device manager in Mac. I don’t remember where I got Betaflight from but definitely not Chrome, it might be from GitHub.


#10

Windows is notorious for messing with drivers. I have a lot of FC that get connected and sometimes just a reboot will fix the issue but if not that driver fixer from impulse should work. You just open the program while the card is connected and it will do the rest. That’s if the FC does connect when it’s plugged in.


#11

Thanks Madman, I’ll try to do it tonight when I have my windows computer. I’m a silverware user and I expected Betaflight to run smoothly but it turned out so different. Betaflight is a mess, I should have known that before.


#12

Hi @FPV_Lover. Sorry I should have paid more attention, I see that you are the original poster. Mac doesn’t seem to have the issue with drivers that windows does. I thought you had been using a windows machine. Are you running the BetaFlight configurator through Chrome browser on the Mac? About a year ago they said BF would no longer be available or updated on Chrome but apparently they changed their minds and it is still updated. But, there is a stand alone app specifically for Mac machines that is independent of Chrome. You may want to install that and try it. I do not have any Mac experience but if the FC does connect to the Mac and doesn’t give you a notice that it does not recognize the device I would try @An_Old_Man’s advice first and look to see what the FC shows up as on the com port it is connected to. It should show as an STM32 device and if it does unplug it, then select “no reboot sequence” and “full chip erase” on the BF configurator. Put the FC into boot mode, the Beecore has a tactile switch/button so hold that down while plugging it in and that should put the card in boot mode which will show up as DFU on the com port of the Mac and BF should also go to DFU instead of showing a com port. If the FC shows as unrecognized or does not show at all on a com port I am not sure what else you could try in this situation and I am not so confident that you would get any results by trying it on a windows machine unfortunately since Mac users rarely have the drivers issues that us windows users seem to encounter quite frequently.


#13

I used windows this time and installed drivers but when I connected the usb cable a message pops up and it says “One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it.” Then I opened betaflight and it failed to connect, after that I run Impulserc driver fixer but it seems to search for flight controller forever.


#14

Did you attempt to reflash firmware or just connect to BetaFlight? If you only tried connecting to BF then I suggest attempting to reflash the firmware. If you did try that then the fact that it would not connect with the Mac or the windows machine says to me it’s more than likely a hardware fault. Hard to specifically pinpoint that sort of thing but it never hurts to take a close look at the components on the FC. You would want at least 10x mag or more to inspect components and their solder joints to the pads on the PCB. There are small pocket scopes that can be had for around 10$ or less and are great for that and they typically have around 35x mag and led that illuminate what your looking at. First component I would look at would be the stm since there are 48 pins although only maybe 1/2 of them are connected in the circuit. If you have a hot air solder station you could just try a reflow. You’d want to be careful of any parts on the card not meant to withstand the reflow temperature though which would be motor sockets and that tactile button switch. If you do not have hot air solder station visual inspection is the easiest way to find a fault but it is not always obvious when there is a broken solder joint. The description you gave of how this occurred for no reason leans heavily towards a component that has a faulty solder joint since it worked and there was no crash or reason it should have just stopped working. That is if the card could not connect to BF and can not reflash the firmware.