Beecore ? - dropping out of the air


#1

So most are aware of the poor voltage supply design of the beecore… and unfortunately I ordered one by mistake. I have some 19.6’s installed currently and it just drops right out of the air towards the end of my flight. It’s only cutting maybe 15 seconds of air time short - and I could just set a timer sooner … but stuff that doesn’t work right just annoys me. Should I banish this board to a build with slower motors (if so how slow) - or just cut my losses and give it away (better than letting it sit in a drawer I suppose).


#2

Punt, solder motor+ straight to B+, and add air wires from MOSFET source straight to B-.
Adds a little weight, but you’ll have the lowest resistance whoop board on the planet! More power!

*Statements and plans may have unexpected issues, have fire suppression nearby.


#3

So is it power supply to mosfets that’s the problem on this board??? I would have assumed it was something with low voltage to the processor or rx.


#4

Um, yo hablo ingles, por favor? Is this a common recipe, @Bobnova?


#5

I’m just tired of walking to pick it up. @burtlo … mas que vale un whoop en mano que dos en el piso. Ha!


#6

I’ve no clue where the actual issue is, but it sounds like voltage droop to the FC caused by motors drawing more than PCB traces can support. If I’m right then direct wiring the motors will fix it.

Droop can be the ground trace having positive voltage on it relative to B-. All the FC cares about is the voltage difference between is + and - pins.

Common recipe? Not especially, definitely not in brushed quad land. It’s more or less how the brushless racers are wired.
I have a background in voltmodding video cards and motherboards for liquid nitrogen cooled benchmarking, it makes perfect sense from that standpoint.
Could turn out to be a horrible idea for a whoop, only one way to find out!

I try not to concern myself too much with the box, in or out.


#7

I said “English, please”.

Bookmarked for future translation. Thanks, @Bobnova!


#8

Hmmm. Worth a try. I can always give it away after. I was just thinking that voltage under load was dropping below a threshold where either the main chip or rx could operate. Would you agree that a also a likely scenario?

Adding, if it is either of the above - nothing can be done about it… best to make sure the mosfets are well supplied…

Also adding, tried with brand new batteries as well as older ones. Same behavior on both.


#9

That’s absolutely what is happening, the question is where the voltage drop is coming from.

If, say, the 3v (3v3?) regulator that supplies the FC need to have a minimum of 3.6v going into it to produce that 3v, we’re screwed as it’s the lipo cell dropping under the minimum and not delivering enough voltage that is the issue.

If on the other hand it’s that the traces from B+ to where FC voltage regulator and motors pull from being too small and dropping voltage due to that, then the battery is still fine and if the motors had a direct battery route those traces wouldn’t be overloaded and wouldn’t drop voltage, so the FC regulator still gets what it needs.

Which one is the issue? Who knows, could be a third thing too.

In large part I’m suggesting it because it’s also a test to see if it fixes the issue, which will point towards the cause.

And because I like suggesting outlandish but not wrong things to see what happens.


#10

…going shopping for a US based furibee f3 or e010s fc now. Any known sources?


#11

Well, no. Sadly.


#12

Looking at gearbest, they have three postings of the board … All at different pricing - two with a bind button and one without. Any idea on differences other than bond button?


#13

Radio I suppose. Don’t really know though.


#14

By the way, the upgraded 59000 banggood motors are pretty good. After I changed to dark editions I’ve been having the same issue with my Beecore sometimes. I figured it would be the powerlead, still using micro jst. Haven’t tried the ‘powerwhoop’ connector yet but it sounds like the same issue. Didn’t get that with the BG motors. They got a little bit less thrust I feel, but the difference with the darks wasn’t as stellar as I had hoped for. And they gave me a minute more flight time.


#15

I’m on the ph2.0 already. Doesn’t fix the drop out - but punches way harder than 59k. I’m just gonna get rid of it. I ordered an e010s. Will try the 19.6’s in that. Plus I get spare stuff too.


#16

I am not sure droop is the only cause. I fitted a Beecore V2 a month ago to an E011. Was initially fine, but just started to drop out, zero RSSI is definitely the reason. However it will do it with a fully charged battery, and in level flight (no sudden current spike / voltage droop), and it never used to. Not sure that sounds simply like voltage droop, though don’t know what it is.