Micro Motor Community

B03 FC + fishpepper ESC set up problem

microbrushless
silverware

#1

Hello there and especially @yets and @silver13,

I’m on my first brushless build and experiencing some troubles. I’ve followed mainly this link from rcgroups to build it but I’m stuck somewhere I guess in silverware config.

Here is an eye candy to motivate your help :


So what is wrong with such a nice rubber wraps ?

Well it is about throttle which behaves weirdly. Let me try to explain…

Using “Throttle to motor” option in silverware : after binding, increasing slowly throttle from bottom to top causes this :

_0% throttle : motors don’t spin = Ok

_20 to 50% throttle : motors start spinning let say at half speed, then increase quickly until the stick reach 50% then spin at lower speed => this is what I don’t understand !!

_From 50 to 100% throttle : motors spin from lower to hight speed. => I guess it should be that, but on the full range of throttle stick instead of half.

And some bonus, as I don’t know if it’s related or not :
when throttle to motors is disable : in accro mode, holding the quad, throttle to 25%, motors spin fast. Then turning the quad of 90degres make motors to spin at min speed, coming back to flat orientation, speed fast again…

well, I hope some more advanced people than me could give me a hint !


#2

Hi Nezo, what protocol are you using? I assume Oneshot because you said you’re coming from the FETS in the other thread? Have you calibrated the ESCs? Have you set your idle correctly in the Oneshot file? Have you taken unticked “Program from TX” in Blheli?

In terms of the behaviour when you flip it upside down, can you set it to level mode and describe what it does then? If holding it in normal orientation does it attempt to flip over?


#3

Hi Yets ! Thanks for answering so fast !

Yes I’m using Oneshot 42 and have tried also the other oneshot.
About calibrating ESCs, I opened them with bheli suite and report min and max values to dvr_esc.c, I tried also the method mentioned by nigelsheffield but as I unticked programming by Tx I don’t know if does changes.

I don’t know about setting idle up… so maybe here is my problem ! what’s the name of the Oneshot file ?

In terms of behavior, it seems to be equal accro or level mode : when I try to put the min amout of throttle to spin the motors, they almost go full speed, then I need to move the quad by hand to find a sort of proper angle where speed is low but it doesn’t react according to throttle…


#4

Why don’t you just instal @yets brushless fork and follow the guidelines there to get initial set up working. I advise going with dshot dma rather than any of the oneshot stuff for ease of set up.


#5

Hi Chaotix !

Yes you’re right, I tried first with that one, and then moved to the NFE silverware I’m using on brushed. But they act the same with my problem. About Oneshot, I have to use this because my pepperfish ESC may work with that (according to the thread I linked on 1st post).


#6

Tinypepper esc works well with dshot300 and the DMA dshot driver also works very well. I use my variety of NFEs fork now but have had lots of success with the Vidzo fork also.
Why are you defining throttle to motors anyway? That’s a test feature which isn’t used in actual flight.


#7

Ok so I’ll give a try to dshot300 and let you know. Just on that threat nigelsheffield mentions that 1S tinypepper ESC doesn’t work with Dshot according to voltage regulation.

I thought using throttle to motor should help me to see how the motors would react according to throttle. I was expecting an almost linear increase of speed, as I was suspecting some acc/gyro issues… but now I think more of some issues betwin FC and ESCs… but with the fact that moving the quad produces change of speed I’m a bit lost !!


#8

Ha, I should have recommended using the brushless fork! D’oh!

Like @Chaotix states, try the brushless fork and Dshot.

Did you try testing in level mode? I’m curious as to what it attempts to do. I’ve had a faulty gyro that does strange things with the throttle in certain modes.

Can you post a video of the behaviour?

The ESC works perfectly well on Dshot or oneshot, the problem is that the 4.2 voltage needs to come down to around 4.17v before all the motors will spin up correctly (at least in my build). It’s to do with the lack of regulator and logic. Regardless, it’ll work fine once you get over the issue.

Bear in mind that brushless motors are not linear so that could explain the throttle jumps. I have added code to help with linearization (thanks to a Rcgroups member). Also, moving the quad in acro will produce different increase of motor thrust as the FC and PIDs are taking control to try to keep the external force (you) from creating errors.

I have an idea what could be causing a few issues but I could be going down the wrong path. Have a go at what has been suggested by a few of us and let us know.


#9

Ok I’ve flashed the FC with your fork, and set to Dshot beta. but then nothing… Arhh I need to resolder the wires before the FETs !!! Soldering iron is warming… and go.

@yets, level or accro act the same. After soldering session I’ll try to upload a video.


#10

Well !! I’m done… I had hard time because while resoldering the wires before the FETs, one small pad of the ESCs jumped from the board and then I struggled a bit to solder back the wire on the thin leftover…

But the verdict is : Now it FLIES !! so thank you guys for this quick and effective help.

Then, 2 things left to me :
_on a full batt I need to wait a bit and plug replug, restart Tx until ESCs want to give power to motors (voltage regulation stuff ?.. I guess I would have to accept that)
_the quad is vibrating a lot in flight. I will have to learn about PIDs I guess…

Have a good day/night !


#11

Glad you’re flying :smiley:

Yes, the full batt and ESCs not working correctly thing gets annoying, however you don’t need to restart TX and unplug. I just give full power on the throttle, coupled with the AIO VTX, it brings down the voltage to the working threshold for the ESCs to reset and work correctly. The ESC was designed to work with the PepperFish FC so it’s not optimal for any other FC.

And yes, that’ll be the PIDs! Luckily you have gestures to tune with and also if you an android app you can use SilverVise to see the PID numbers/Sets to make it easier (or just simply use debug to pull the numbers after tuning).


#12

Hem… I got SilverVise installed on an android device. Now I can see battery voltage and realize that motors accept to spin only when batt is under 3,8V…

According to nigelsheffield’s advice, I should take signal from after the fets and use pullup resistors, and use Oneshot 42… but then I’ll have again the weird symptoms !
I soldered resistors in place of caps were, do you think it would improve signal to solder them between motors pads ?


#13

Brushless doesn’t need the mosfets or anything after them, just the motor signal from each F0 pin. Remove the fets completely and take signal from the fet gate pad. Just use d-shot it’s easiest.


#14

Also, you need to calibrate the battery in the code, your 3.8v threshold is likely wrong. As Chaotix states, remove the resistors (and caps). If you haven’t read this, it will give you some pointers http://sirdomsen.diskstation.me/dokuwiki/doku.php?id=more_brushless_setup_info2


#15

Thanks both Chaotix and Yets for your help.

I checked battery voltage with a voltmeter while silvervise was running and quad on. The voltage is quite precise (SilverVise says 3.93v when my tester says 4.00v).

I had to wait let’s say 5mins on full batt before I could spin the motors with Dshot and signal before gate.

What about Nigelsheffield’s thread ? Don’t you give credit to it ?


#16

I defo give credit to Nigel’s work, he’s the one who first spotted the problem for Silverware. I am running two quads with the pepperfish ESC (one clone), one is running Oneshot without caps/resistors (one signal wire is even running straight from the MCU) and the other quad is Silverlight brushless board running DShot600 where there are no motor caps or resistors. Essentially signal is coming straight from MCU again. Both quads display the same behaviour on full batt and start running up properly at 4.16v.

So all in all, it’s from personal experience that we’re explaining that the caps/resistors are not needed. Have you removed the bits and bobs?


#17

My experience is :

1 ESCs spin motors from full batt on Oneshot 42, signal taken after FETs on motor - pads… But motor spin isn’t controllable.
2 Everything works with Dshot and signal taken from fet’s gates… But Vbat must be lower than 3.8…

Do you think removing FETs and some resistor would improve this ? Right now I was suspecting my signal wires (but may be a bit stupid…)


#18

Please remove the FETs if you’re not planning on going back to brushed on the board. Honestly, you don’t need the FETs, resistors and motor caps. If you remove the FETs you can use Dshot, Blheli Passthrough and you won’t have the issues.


A H8 mini board customized, removed arms, FETs, caps, resistors, running on a clone Pepperfish/TinyF1sh ESC. Same principle


#19

So you mean the presence of FETs could provoque some bad behaviour ?


#20

Likely, yes. If you are getting the signal from the FET gate while the FET gate is still in the signal circuit, it’s likely imo. I’m no electrical engineer though :smiley:

If you can, remove the FET, the 10k pull up/pull down resistor.