AlienFlight Classic Narrow interactive manual


#309

@roshu,
If you want to, try this one. Again, it won’t help the fet issue, but I have the same board from MMW and was guided to this one.
The Chief Scientist himself created this one: https://www.dropbox.com/s/v3ccvqnaeb588cv/MultiWii_2_3_Benedikt-base-build.zip?dl=0

Edit:
What version of he gui do you have?


#310

@Kamsleo69 I think it’s 1.8 but I’ll have to double check when I get to work tomorrow. Oh and 64 bit version won’t load on my lap top, only 32 bit works, e.g I can see the imu at work


#311

I am also using windows 10, had a heap of trouble and yes the same as you only 32 would work for me as well. Most of my issues were my own. I have a mechanical background so all of this computer driver stuff was new to me.
The gui linked in the first post above is 2.4,
It’s the one I had help getting started. Maybe try that:
https://drive.google.com/uc?export=download&id=0B8_pEI-_SlWGZFRQX3ZhNVlXbU0


#312

I am back :slight_smile: thank you @Kamsleo69 @pedro147 for the info you gave me, and off course thank you @Benedikt for the help as well, the board works now!!! :slight_smile: However, im still stuck with some issues (and believe me I tried for hours, even asked my colleagues for help :frowning: ). This is the problem, I put everything together, fleshed Alienflight with the most recent firmware, plugged in my LemonRX (the one from this site), added the orange module to my Taranis plus; made a profile in which i turned off the internal RF and used the module with DSMX, and was able to bind the receiver to Taranis. But, no command goes through. In my GUI i can see the drone moving, but when I give it any commands (throttle, etc.) nothing goes through. The LED on the receiver is red so I am assuming its binded but it still doesn’t work. What am I doing wrong? I played with the firmware a bit to allow for DSMX_bind_22 and uncommented all 4 lines for SPEK_bind. I am lost! :frowning:


#313

Hi @roshu
Glad to hear things are progressing
Unfortunately you lost me at Taranis. I use a Spektrum dx6i.
Hang in there we’ll get some help from someone who uses your tx.
@pedro147, any ideas?


#314

No unfortunately I am Devo 7E and Spektrum DX6 Semi Savi only :grinning:

If @roshu is seeing gyro movements in the GUI and the Lemon RX LED is solid then it seems that the bind was good.

I would be expecting a problem with stick travels. Is the quad arming by whatever method has been set up. Either the default left stick down and to the right, or switch arming set up in the GUI.

I know that @Complacent1 is a Taranis guy of repute and on AW FC Josh and quite a few others use them as well as of course The QuadFather @Benedikt is a Taranis PowerUser :smiling_imp:


#315

I may be able to help. In the MWgui on the right are some horizontal bars corresponding to your tx channels. @pedro147 mentioned stick travel and I believe this is where your problem lies. These graphs should go from 1000 at stick low or left and 2000 at stick high or right with a centre point of exactly 1500. Could you connect and bind the fc and tell us what those figures are just now. We make adjustments in the taranis to get the right figures. Without setting this part up correctly you may not be able to arm and could have drifting problems.


#316

@Chaotix and @pedro147 the GUI looks like this when I connect to the port and start it:

im using Taranis for the first time so I am still learning how to set up the settings there :cry:


#317

@Chaotix and @pedro147 and everyone else actually, quick update: I made sure that my profile on Taranis is set to use external module as DSM2 - DSMX and also made sure that my travel ranges for 4 channels are between 1000 and 2000 exactly. One thing I noticed is that my pitch is CH1, roll is CH2, throt is CH3 and yaw is my CH4. That doesn’t matches with the order of THROT, ROLL, PITCH, YAW from the picture above. Another thing I noticed is that even though my Lemon receiver binds to Taranis (solid red light) when I start the GUI the above numbers don’t match the set values for the ranges I changed on the controller :flushed: All i can think off is that when I was changing the firmware to flesh the flight controller I messed up the settings, if thats possible, that the receiver binds but the protocol is wrong and nothing goes through? This is what i changed (uncommented) in the config.h:

I am lost but also happy I am learning :slight_smile:


#318

You will need to change the channel map to correspond to your tx, I’m not sure where that is in the mwii config.h @pedro147?
You change the endpoints in the tx for each channel in the guide, I think page 7 in the taranis menu but at work so can’t check for a few hours. Alter the low end first then high end then use subtree on the same page to get the centre to 1500.
I’ll be able to help more once I get home.


#319

I’ve already done that on the Taranis (adjusting end points) so I think that’s ok now, I followed detailed instructions from a YouTube vid :slight_smile: I think it’s the config.h where I need to tweak some things


#320

You will have to show us exactly what you changed and how please :grinning: Here is the default code and I would change it back to that.

AFAIK seeing as you are using DSMX you should not have to change anything in the code. I am pretty sure that the only time you need to change any of that code you have been playing around with in config.h is to change between DSMX and DSM2 receivers.

However with these FC’s you have to reverse aileron and rudder on your TX. This is why your channels are screwed up in the GUI I suspect.


#321

What you have done is set the tx to send 1000 to 2000 which it does anyway, what you need to do is change that so the board sees 1000 to 2000 by changing the values in the tx.
Have you calibrated the taranis? If new to it you may not have, long press the menu button and go to page 9 and follow the instruction. If done already, good.

This is the same as Peter posted above but set for DSMX 11ms which I’m flying a Classic and a Pedrowii with Lemonrx and Taranis fine.

Channel map can’t be changed as far as I can see in the code but on the Taranis you can map inputs to wherever you want. Go to the outputs page 6, select ch1 to edit, change source to Ail, exit out and repeat for each until it corresponds to the gui. AETR is how mine is set.


#322

@pedro147 we must have been almost typing at the same time there :smiley:


#323

Thanks Steve I can never remember some of this shit :smiley: Not even sure if my RX’s are DSMX or DSM2 but what the hell, I get there in the end :grinning:


#324

I’m only here because of you and Adam, collective memory comes in handy :wink:


#325

That is what pigeons say too :grinning:


#326

Hi all!

Just bought my AlienFlight Classic Narrow and I’m having trouble with the MultiWii Configurator. I followed the directions stated above to the tee. I already had Arduino and MultiWii downloaded - all I did was just plug into USB and run the MultiWii Config executable.

The com port isn’t showing in the GUI. However, the com port is showing correctly in the Arduino GUI. The cable is working and is the right kind of data cable, I was able to connect my ESP32 and ESP8266 to the PC and upload sketches using the same cable.

You can see there are no options under “PORT COM”.

I am able to upload the AlienFlight arduino sketch to the AlienFlight FC. It says “finished uploaded” and seems to work. The blue light on the FC turns on fine when plugged in.

First things first, do I need to be able to run the config GUI? Can I just use upload the sketch to the FC board and use it? Is the GUI all that important?

Thank you in advance for any help!

Edit: I am on Ubuntu 17.10 and have 64-bit OS

Edit 2: Got it working!!! This thread gave me the answer: http://www.multiwii.com/forum/viewtopic.php?f=18&t=5930

This part fixed it:

It may be that multiwiiconf does think /dev/ttyACM0 is a serial device. You can fix this in a number of ways:
create a symbolic link to an unused ttyUSBx, e.g.

ln -sf /dev/ttyACM0 /dev/ttyUSB42


#328

Welcome to the Alien :alien: series of flight controllers. I have never seen or heard of anyone using Ubuntu to set up these flight controllers unfortunately. One guy used Linux but it’s a Black Art and he had
issues. Windows is the main OS used and all but the latest OSX work OK although there are often issues to sort out with Windoze, usually related to the Path to the Java (JRE) within Environmental Variables. I have zero experience and knowledge of Ubuntu sorry.

Well the GUI allows you to be able to adjust all parameters of the FC like all PID’s, rates, gyro calibration (although this can be done via stick commands without using the GUI) motor arming and switch setup for flight modes and motor arming.

So the default settings are Flight mode acro only and motor arming Mode 2 is left stick down and to the right. Disarming by left stick down and to the left. So as you can see it is possible to fly on the stock settings without having access to the GUI but very limiting and if like me you cannot fly Acro you are done for :slight_smile:

Did you download the latest Java Runtime Environment as per step 9c in Set-up Steps in the opening post?

EDIT - these may help with stick commands for ACCEL calibration on the default settings


#329

Pedro - appreciate the quick response and help!

I got it working. See my edit #2. Thanks!