Micro Motor Community

AlienFlight Classic Narrow interactive manual


#289

What shows up in the tools tab of Arduino with the FC plugged in?

Can you get a device manager window like mine I am on Windows 7 too

You should be able to change your view like this


#290

The row of tabs sounds like you had the AlienFlight Arduino sketch open?

Are you on Facebook?


#291

You can try this.

Select Com 7 >Reconnect >Start


#292

Looks like MultiWii works fine.
See attached screen shot.

Are there any MultiWii parameters I should change?

Yes I am on facebook,


#293

This is the alternate Device and Printer shot after opening Arduino and
then plugging MicroUSB into FC

To find me in Facebook look for David Lowry, Georgia Tech, Arlington, VA


#294

This is what Arduino looks like with AlienFlight Buzz selected as a
File\Open “Verify”

I get the following error messages.


#295

Good so you are connected to MW and to adjust flight modes etc have a read of this. All this info is in the first post Basic setup guide actually :slight_smile:

That all looks normal but all you have open there is the bog standard opening Arduino sketch, not the AlienFlight Buzz. To open that you need to browse to it, within whatever folder/file structure you have stored it in on your PC. The procedure in Arduino is to browse to the sketch you wish to upload to your FC and click upload. No need to verify with a standard AF-Buzz sketch because it will compile . No real need to ever verify because if you modify a sketch and the compiler doesn’t like it, you will get an error anyway.

I asked about Facebook because we have a great AlienWii/Flight group there if you feel like joining us. There is always help there pretty well 24/7 :grinning:

If I see your name come up as an applicant I will let you in and get you on your way.


#296

Hi Everyone, first time setting up AlienFlight classic narrow + lemonrx satRX and having an issue with either my transmitter or satRX or configuration in MultiWii. Looking for a little assistance here.

Coming from micro scisky 32 board. Snagged a AlienWii and Lemonrx satRx off MMW last week.

Installed Arduino on win7, and downloaded AlienFlight Buzz sketch. cleared eeprom and then selected arduino leonardo and COM port. loaded up AlienFlight Buzz sketch verified and uploaded to FC. Firmware flashed successful. Next i downloaded MultiWii 2.4 and started the 32bit Win GUI. Cal ACC, set rates/expo, etc. Unplugged board. Next I attached the lemonrx satRX with the included cable to alienflight FC and held down bind button while plugging in usb to laptop. Then powered up my DX6i in bind mode. Successful Bind. I unplug board again and install on bottom plate h frame and mount/plug in motors for first test flight.

PROBLEM STARTS HERE:

Rudder and Aileron (yaw and roll) were reversed. To be expected. I figured this out because the default arm wouldn’t work. However i was able to arm by pushing the left stick all the way down and to left, instead of right. After arming, was able to spin up motors and hover, but again, rudder and aileron were reversed. Also at this point, I am unable to disarm the motors again with stick commands. So I unplug and replug battery and restart tx.

Now I turn on REVERSE on rudder and aileron in TX menu. After this, I am unable to arm motors at all.

In the multiwii GUI after I bind board but before building the quad, I noted that the first 4 channels looked to be responding correctly to stick input movement. HOWEVER - moving the switches on my TX showed no movement on any of the AUX channels. Also AUX2 is somehow linked to YAW. AUX2 also channel does opposite whatever YAW channel is.

Does anyone know anything about binding lemonrx satRX to DX6i? Or does anyone recognize the problem im running into? Really appreciate any help here guys.


#297

I know nothing about dx6i, listen to chrisdo!


#298

@mcleanquads got some support from @Jtwalkz and me on FB.
Just let us know if you’re up in the air Alex.
And as said on FB @madman1412 is the expert when it comes to :alien: and dx6i.

If aux2 is still moving while you give yaw inputs check that there isn’t some kind of mixer active (mixer in dx6i menu should be set to inhibit).

@pilsnerpopper there’s no way to assign switches with a dx6i like with other radios (dx6, Taranis…)


#299

Anybody tried this with frsky rx yet? Mine came in today and should have some time to try it out this weekend. I’ll update. Would LOVE to abduct an alien without any orange modules in the way.


#300

Jakob Flodman has done this :slight_smile:


#301

Well I have the hardware done and the tx bound but not having luck seeing stick inputs in multiwiiconf. Hey @pedro147, did Jakob do a write up about this somewhere? Just trying to get a bit more input on the sketch changes required

I commented out the spektrum bit but there are two define sbus sections:

/******************************* SBUS RECIVER ***********************************/
/
The following line apply only for Futaba S-Bus Receiver on MEGA boards or PROMICRO boards.
You have to invert the S-Bus-Serial Signal e.g. with a Hex-Inverter like IC SN74 LS 04 */
//#define SBUS THROTTLE,ROLL,PITCH,YAW,AUX1,AUX2,AUX3,AUX4,8,9,10,11,12,13,14,15,16,17 // dsm2 orangerx
#define SBUS THROTTLE,ROLL,PITCH,YAW,AUX1,AUX2,AUX3,AUX4,8,9,10,11,12,13,14,15,16,17 // T14SG
#define RX_SERIAL_PORT 1
#define SBUS_MID_OFFSET 988 //SBUS Mid-Point at 1500


#302

He did post some scant info on AW FC or the Hackers group on FB so best to tag him there :grinning:


#303

Hello everybody, how do you do? Newbie here jumping onto the micro drone train. Ran into some issues with my first ever build and was wondering if I can get some insights. Quick disclaimer, I spent hours trying to figure out what’s going on with both my hardware and software, and after many attempts, links, forums, I decided to seek help, so don’t be gentle, after all I gotta learn. Anyhow, first here’s my build:

after I completed the drone, I installed the Arduino, and fleshed the board (alienflight classic narrow) with multiwii Firmware I got from Alienflight website. Upon unplugging the board from pc and plugin in the battery front right motor starts spinning right away. I tried several different sketches and nothing seams to work, motor starts spinning right after I plug in the battery. What can cause that problem? I was gonna play with the code today but another issue arose. Now I can’t even get the board to be recognized by the pc, when I plug it in, i hear the sound for connection and then after few seconds it disconnects, and it repeats. So I’ll try deleting the device and reinstalling arduino, and I hope I’ll be able to upload new sketch.

I might be missing something here, but as I said I literally just started playing with drones and arduino programming so any help is appreciated. Thank you!


#304

Welcome :grinning: Motor spinning on connection can be a bad FET I believe. Where did you purchase the FC please?

That would however not explain the lack of connection now. Can you go to Device Manager in Windows and look under the Ports entry, expand it and tell us what is showing up there. Also what OS are you on?

That’s a great looking little frame and camera mount there. What is it and what cameras does it fit please @roshu


#305

Hi @pedro147 my apologizes for replying late and thanks for the response. I bought the FC from micro motor warehouse. Is there a way to check the FET using an oscilloscope? I got one at work. Regarding the connection, the board connects to my pc (Windows 10) via usb and everyhting is ok (this is when eeprom is cleared). The FC is read as:

but, as soon as I flesh it with firmware I get this, it gets stuck in bootloader:

I haven’t even try connecting it with my RC control (Taranis and Orange module in the back cause I also bought LemonRX DSMX satellite receiver). Any ideas why it might be doing this when I put the firmware on it?

About the frame and the FPV cam, I designed the frame myself. The main frame is 3mm carbon fiber with holes for motor mounts which I 3d printed in black semiflex. For the electronics i printed two pieces in PLA, one to hold the FC and the RX and the other to hold a mini FPV (VM275T 5.8GHz 25mW 48CH NTSC/PAL Mini VTX 600TVL FPV Camera (Cloverleaf Antenna)) camera from Hobby King. The two pieces are held in place with 3 K18x5mm screws. I got the files if anyone needs them. The total weight is around 45-6 grams with the battery and around 36 without it.

Any ideas what I should do next?
Thanks in advance


#306

You can check if the PWM signal is being sent from the Atmega to the FET that controls that motor but unfortunately I cannot tell you how sorry. This FC has big problems so I would contact Benedikt or John Tivet at MMW and see what they can do about this assuming that the board is pretty new and has not suffered any user damage etc

Thanks for the frame info, it’s a great looking frame and good luck with the FC :grinning:


#307

@roshu
MMW has great customer service, I second @pedro147 comment to contact them.
Even if something can be done w software issues a blown fet will ground you regardless.
Just curious, when you say you try to flash firmware, which firmware specifically?


#308

@pedro147 thanks for the quick reply. Yeah I will definitely reach out to those guys to get some insight. Regarding the FET, I already spoke with a EE colleague who suggested the same thing so we might do that but after I hear back from Benedik or John.

@Kamsleo69 for the firmware, last one I used is:
http://alienflight.com/wp-content/uploads/ALIENFLIGHT-BUZZ.zip
I looked through config.h and as far as I understand everything there seamed fine, but again I just started learning arduino so…