Micro Motor Community

AlienFlight Classic Narrow interactive manual


#269

Actually Jacob just posted some firmware change details as such -

“How to change to frsky.
In config.h
Comment out #define SPEKTRUM … line 390
Remove comment from //#define SBUS
Line 416,417 depending on yor channelorder”


#270

Fresh ground - sweet! I’ll have a play during the week and report back. Thanks for the replies. :wink:


#271

Got a link for a suitable Rx to try that?


#272

What Jacob’s RX @Benedikt? Build your own only but he might send you one :grinning:


#273

Assuming the uSKY works with SBUS, shouldn’t a FrSky XM / XM+ supporting SBUS not also do the job?
Those are available on BG and a lot of other sources.


#274

Do you mean something like this @las


#275

Yes, exactly.


#276

I could just about get rid of my orangerx module if I could get my aliens switched over. May have to get a couple of these tiny frsky rxs


#277

I don’t fly Frsky but it would be good to know if that RX from Banggood would work well with an 8 bit AlienWii/Flight :grinning:

Who is going to be the Guinea Pig they are only 10 bucks ?


Open source Alienflight FC
#278

Alright I have one from BG on the way. Should be here in a few weeks to test


#279

Can someone please explain step 12 of the “Set-up Steps”? In particular how does one “Open up Multiwii Conf for your OS” and how does one “click start”?

Thanks Much


#280

What OS are you on @WDL

See if this helps


#281

Thanks Much Pedro147

I’m using ancient technology, Windows 7 Pro.

Your info helped on the MultiWii. But I have to double click on the "Folder “MultiWII 2 4” on my desktop, then double click as required to drill down to C:\Users\dlowry\Desktop\MultiWii_2_4\MultiWiiConf\application.windows64 then I double click on MultiWii Conf and then click “RUN” on the pop up box. Not elegant but at least it works.

The Arduino program I have uninstalled and reinstalled 3 times and I (always) get the following error messages:
Arduino: 1.8.2 (Windows 7), Board: “Arduino/Genuino Uno”

Exception 0xc0000090 0x0 0x0 0xf2842
PC=0xf2842

syscall.Syscall12(0x75e0103d, 0xa, 0x1272f0e0, 0x12730900, 0x0, 0x0, 0x1, 0x400, 0x12741200, 0x0, …)
/home/jenkins/go/src/runtime/syscall_windows.go:196 +0x4a
syscall.CreateProcess(0x1272f0e0, 0x12730900, 0x0, 0x0, 0x1, 0x400, 0x12741200, 0x0, 0x12423328, 0x124232d4, …)
/home/jenkins/go/src/syscall/zsyscall_windows.go:583 +0x112
syscall.StartProcess(0x1271f680, 0x41, 0x126c5960, 0x1b, 0x1c, 0x124233e0, 0x0, 0x0, 0x0, 0x0)
/home/jenkins/go/src/syscall/exec_windows.go:326 +0x722
os.startProcess(0x1271f680, 0x41, 0x126c5960, 0x1b, 0x1c, 0x12423514, 0x126a1520, 0x0, 0x0)
/home/jenkins/go/src/os/exec_posix.go:45 +0x293
os.StartProcess(0x1271f680, 0x41, 0x126c5960, 0x1b, 0x1c, 0x12423514, 0x0, 0x0, 0x0)
/home/jenkins/go/src/os/doc.go:28 +0x53
os/exec.(*Cmd).Start(0x126af600, 0x0, 0x0)
/home/jenkins/go/src/os/exec/exec.go:358 +0x6fa
os/exec.(*Cmd).Run(0x126af600, 0x0, 0x0)
/home/jenkins/go/src/os/exec/exec.go:276 +0x2b
arduino.cc/builder/builder_utils.ExecRecipeCollectStdErr(0x126edd20, 0x56c313, 0x15, 0x1, 0x5f4880, 0x614ef0, 0x0, 0x0, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder_utils/utils.go:413 +0x118
arduino.cc/builder.(*GCCPreprocRunnerForDiscoveringIncludes).Run(0x126edd00, 0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/gcc_preproc_runner.go:93 +0x23c
arduino.cc/builder.runCommand(0x1246c000, 0x5f39b0, 0x126edd00, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:183 +0x57
arduino.cc/builder.findIncludesUntilDone(0x1246c000, 0x126edc60, 0x538ca0, 0x126cbb00, 0x1270f200, 0xd, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:331 +0x1810
arduino.cc/builder.(*ContainerFindIncludes).Run(0x614ef0, 0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:149 +0xdfd
arduino.cc/builder.runCommands(0x1246c000, 0x12423cc0, 0x22, 0x22, 0x1, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:191 +0xe2
arduino.cc/builder.(*Builder).Run(0x12423de4, 0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:124 +0x89f
arduino.cc/builder.RunBuilder(0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:222 +0x35
main.main()
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/arduino-builder/main.go:338 +0x1360
eax 0x0
ebx 0x32fc6008
ecx 0x0
edx 0x32f60000
edi 0x5274
esi 0x32fc6000
ebp 0xcf67c
esp 0xcf654
eip 0xf2842
eflags 0x10212
cs 0x23
fs 0x53
gs 0x2b
C:\Program Files (x86)\Arduino\arduino-builder returned 2
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


#282

So you installed Arduino OK I assume ?

So when do you get this error. You will have to explain exactly what you are doing and at what step you have problems please :grinning:


#283

Thanks for your time and your patience, I open Arduino attach the USB to my FC and run File\ Examples\ (Built-in Examples) 01.Basics\Blink “Verify” and I get the error messages I attached. Any suggestions?


#284

I also get the same error messages when I run Arduino Files\Examples(Example for Arduino/Genuine) EEPROM\eeprom_clear


#285
  • Have you selected board - Arduino Leonardo under Tools> Board and the Com port that shows up in Device Manager as having Arduino Leonardo connected to it (this is what Arduino sees the FC as because it uses the same STM32 chip as the Arduino Uno does)

  • Can you open the MultiWii GUI, or are you getting a Java error?

  • Open Device manager, expand the Ports section and give me a screenshot of what is showing with the FC connected please

EDIT - In your error message it is showing that Arduino Uno is selected not Arduino Leonardo


#286

Pedro147 you are my hero for staying with this.

I selected Board Arduino Leonardo and got the same error messages when tring the Example Blink Verify.

Here is the screen shot (I hope this is the photo you wanted?).


#287

This is what my MultiWii screen looks like.


#288

This is what my Arduino screen looks like,

Previous versions had a row of tabs that are now missing.