Alien brushed FC not connecting Multiwiiconf


#1

I have not powered up any of my Alien Brushed boards in over a year, until recenty. Unfortunately I cannot connect any of them. Multiwiiconf opens just fine, Connect board and click connect. Multiwiiconf freezes and I cannot click any buttons. I checked the device manager
device%20manager
**other Devices ; com6. Any ideas what has happened, since the last time I flew and had no issues connect these boards.


#2

Are you opening up the 32 bit version of Multiwii GUI? It’s been a while since I have messed with MW, but it seems like I recall you have to use the 32 even if your PC is 64bit or the GUI will freeze up.


#3

Thanks for the reply…Yep using 32bit, I have also tried uploading a new skech to the FC, after erasing old on, now getting com13 already in use error. This last year has been a total waste for me and getting any new quad flying, brushed or brushless. This just tops it all off for me. Now my goto brushed alien FCs not working either.
3 alien FCs not ale to arm, or connect to multiwiiconf (com13 error already in use)
3 F3 or higher boards (brushless) unable to connect to BF or CF (unrecognised usb device)

I am about ready to quit this hobby and sell all my sh*t as this should not be so frustrating, but more fun than anything, but of late, no fun to be had at all. :rage:


#4

Also when i start MWC it does not show the Version number. See below
MWC%20Vnumber


#5

Sorry to hear about the rash of bad luck. It’s bound to get better.
I’d drop back and make sure Java was current and make sure Arduino is playing well with the others too. Could be driver issues in general since your BF builds are giving you a fit too.


#6

Remember USB data cables can become flaky after a lot of use, the common item in all of this could be a bad cable.


#7

Hey thanks for the reply. I love the idea it could be a cable…but I have tried dozens. I wish that was all it was!!!


#8

Cheers man, rash of bad luck… if it wasn’t for that Id have no luck!! :wink:

I too believe it is driver related, and have tried for weeks to get the right driver, even uninstalled all USB driver and started from scratch, still have issues… So very very frustrating.
I’ve tried impulse RC app also, no joy.