Micro Motor Community

About the setup questions category


#1

Dont know where to start? Something wrong with your micro quad and you cant figure out what? This is the place to ask!


#2

scisky responding slowly to tx input,also using dx6 tx


#3

Unsuccesful attempt to communicate with FC using Arduino. Got these Arduino error messages:
Arduino: 1.8.2 (Windows 7), Board: “Arduino/Genuino Uno”

Exception 0xc0000090 0x0 0x0 0xf2842
PC=0xf2842

syscall.Syscall12(0x75e0103d, 0xa, 0x1272f0e0, 0x12730900, 0x0, 0x0, 0x1, 0x400, 0x12741200, 0x0, …)
/home/jenkins/go/src/runtime/syscall_windows.go:196 +0x4a
syscall.CreateProcess(0x1272f0e0, 0x12730900, 0x0, 0x0, 0x1, 0x400, 0x12741200, 0x0, 0x12423328, 0x124232d4, …)
/home/jenkins/go/src/syscall/zsyscall_windows.go:583 +0x112
syscall.StartProcess(0x1271f680, 0x41, 0x126c5960, 0x1b, 0x1c, 0x124233e0, 0x0, 0x0, 0x0, 0x0)
/home/jenkins/go/src/syscall/exec_windows.go:326 +0x722
os.startProcess(0x1271f680, 0x41, 0x126c5960, 0x1b, 0x1c, 0x12423514, 0x126a1520, 0x0, 0x0)
/home/jenkins/go/src/os/exec_posix.go:45 +0x293
os.StartProcess(0x1271f680, 0x41, 0x126c5960, 0x1b, 0x1c, 0x12423514, 0x0, 0x0, 0x0)
/home/jenkins/go/src/os/doc.go:28 +0x53
os/exec.(*Cmd).Start(0x126af600, 0x0, 0x0)
/home/jenkins/go/src/os/exec/exec.go:358 +0x6fa
os/exec.(*Cmd).Run(0x126af600, 0x0, 0x0)
/home/jenkins/go/src/os/exec/exec.go:276 +0x2b
arduino.cc/builder/builder_utils.ExecRecipeCollectStdErr(0x126edd20, 0x56c313, 0x15, 0x1, 0x5f4880, 0x614ef0, 0x0, 0x0, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder_utils/utils.go:413 +0x118
arduino.cc/builder.(*GCCPreprocRunnerForDiscoveringIncludes).Run(0x126edd00, 0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/gcc_preproc_runner.go:93 +0x23c
arduino.cc/builder.runCommand(0x1246c000, 0x5f39b0, 0x126edd00, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:183 +0x57
arduino.cc/builder.findIncludesUntilDone(0x1246c000, 0x126edc60, 0x538ca0, 0x126cbb00, 0x1270f200, 0xd, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:331 +0x1810
arduino.cc/builder.(*ContainerFindIncludes).Run(0x614ef0, 0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/container_find_includes.go:149 +0xdfd
arduino.cc/builder.runCommands(0x1246c000, 0x12423cc0, 0x22, 0x22, 0x1, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:191 +0xe2
arduino.cc/builder.(*Builder).Run(0x12423de4, 0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:124 +0x89f
arduino.cc/builder.RunBuilder(0x1246c000, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/builder/builder.go:222 +0x35
main.main()
/home/jenkins/workspace/arduino-builder-all-cross/src/arduino.cc/arduino-builder/main.go:338 +0x1360
eax 0x0
ebx 0x32fc6008
ecx 0x0
edx 0x32f60000
edi 0x5274
esi 0x32fc6000
ebp 0xcf67c
esp 0xcf654
eip 0xf2842
eflags 0x10212
cs 0x23
fs 0x53
gs 0x2b
C:\Program Files (x86)\Arduino\arduino-builder returned 2
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Any Help is appreciated!!