A little Qreacher Whooping


#41

@quadlifepro 30 is high for a deadband. I’m confident you understand it’s purpose and therefore that you needed that much. But - we can improve that. For whatever reason - the maker fire does not read centered sticks as centered ( that’s why you needed 30 deadband). Go to the receiver tab with your radio on (no battery needed) and adjust subtrim and endpoints/scaling on your transmitter for all channels till you get close to 1500 at center stick and 1000/2000 at endpoints. Adjust throttle range close to 1000 to 2000. Then back both deadbands back to 8.


#42

Okay, I did exactly as you suggested, and it is flying really really well, with a random twitch every here and there though… Also, I was flying in my bedroom when I flew out into my kitchen it failsafed on me I think, (airmode is enabled) and it went haywire!!! lol it regained control, i flew it back to my room and then it failsafed again and went haywire, so i am wondering why i got such strong signal loss so easily… Ill double checdk the failsafe options though to make sure motors stop instead of it just flying away on me lol


#43

You’re right on the money with that. Also make sure the thin antenna wire is not touching anything else on the board. If all else fails - rebind. Sometimes a bad bind will look good on the ground - then act funny in the air. Hard to say of the random twitch is the inherent ppm gitter in these built in receivers (could try deadband 9 - but no more should be needed) or if it’s related to your sketchy signal connection.

Worst case scenario - you do a cli dump to save all your work - and make amazon prime eat it and send you another. A lot of people have had similar issues with this one - some work it out & some just replace.


#44

I got mine on prime too. But if I had it to do over again… I would have bought it piece by piece. The only things still makerfire on my makerfire are the camera and fc.

But for BNF - it’s a good starting point. If you don’t want to replace with prime - Kados stands behind them, ships fast, and is a lot cheaper. I’ve heard he had some kind of upgraded antenna too. I’d email him first to communicate that you’ve had problems and request his upgrades.


#45

Jitter can be bad enough to jump values so much it’ll trigger failsafe very occasionally. Also can move aux switch values enough to disarm and rearm. Watch the ticks in modes tab for a few minutes to see if they jump significantly.


#46

@chatoix, I will absolutely check for that. Some more insanity to throw into the mix you guys…

after the said failsafe flight - I let it cool down for a little, checked to make sure the antenna wasn’t on anything. (and it was like smashed flat onto all of the components so I decided to “air it out” but make sure it wasn’t touching anything…)

I then plugged back in with 2 different batteries, no throttle response, but the lights look like they “arm”… but yeah totally a dead whoop, so i plug it into betaflight to check out the receiver tab, and the rx still has signal and is still bound to the dsm2 on my tx… so It should be flying just like it was before but it is not… So I am thinking I may also need to rebind my tx to the fc again just for a “proper bind” for good measure but I am not sure what the steps are to rebind to the flight controller…

I’m thinking if a rebind doesn’t work, i shall save my progress, and start over by sending it back to the prime and get a replacement and trying again… I got a taste of the whoop… and it was stupid delicious. I want more!!!


#47

Don’t forget to save your cli dump so you can save time and load up the next one.

Check in configurator if it is arming. Icon at top.


#48

I won’t forget to save the cli dump, but good call! The switch is showing it should be arming, but the “arm” icon isn’t yellow like the “airmode” icon is…

Airmode and arm are both set up on the same switch, aux 1, when I flip the switch to arm only airmode goes yellow. Arm stays gray…


#49

It’ll do that if all the requirements to arm are not met (sitting flat, has battery, something else), as long as the pointer is in the right area I think you’re good.


#50

It will arm without a battery. But not if throttle is above mincheck, too far off level, or motion is sensed.


#51

Okay you guys, so a little more about the whoop sitch…

I will start with this - Yes I started it off wrong this experience the wrong way by not looking for instructions. It didn’t come with instructions, and the support@makerfire.com card i had gotten in the box was a bogus email address. So i spent an hour of my time trying to learn how to bind, when i should have just gone to the crazypony website and I would have been able to bind in 5 minutes or less.

Once I remembered that the internet existed, I decided to slow down and start reading, and listening to everything you guys were telling me. got it flying, had some issues with fly away, and then it just stopped working. the RX was still bound to my TX, but would not arm and fly anymore… I had to go out for a few hours, came back home, passed out and woke up again with a fresh mindset ready to give it a go again…

I decided to read all 56 pages of the thread on RCgroups to see what was going on, and get a better understanding of this product.

After I did this, I had tried a lot more combinations of things to try to get it to arm and fly, i also went into my TX to change the signal to dsm2, but it still wasn’t working. so i saved my CLI dump, and then did what @bobnova suggested which was to reflash the newer firmware on it before calling it quits…

I flashed successfully from # BetaFlight/SPRACINGF3EVO 3.0.1 Oct 18 2016 (which is HELLA old) to the latest spracingf3evo betaflight which i believe is 3.1.6 , and was able to successfully set up all settings, configuations, and PIDs just like the last time, and was able to actually bind via dsm2, showed movement in RX tab… Everything was looking SWEET :slight_smile:

until I plugged in the battery to test it and it still wouldn’t fly… So i went back to betaflight and it wasn’t showing RX connection… so i rebound it powering up via USB, and it would successfully bind and show RX movement in betaflight, but then would lose bind when I plugged in the battery… i must have bound this sucker like 10 times already and nothing is sticking… Ive tried activating serial RX in uart1 and uart3, ive tried so many different combiations, and I’ve basically had enough and am ready to call it quits on this little guy.

Im frustrated though. I will admit I spent an hour of my own time wasted from not going straight to the crazypony website, but seriously? If a product has a design flaw, you would think the company would be more willing to accurately support their product vs including a support email address in the box that doesn’t even exist! If it wasn’t for this outstanding community, and the amazing help you guys gave me today I’d literally be having a meltdown…

I’m crazy sometimes, but the crazypony tiny poop I bought made me feel absolutely insane today. lol I will be sending it back to amazon, and looking for other whoop options in the future… as much as I hate saying it, right now may not be my time to whoop… I think I may rather build my own whoop when I finish a few of the brushed proejcts I currently have opened…

QUADLIFEPRO: 0
tiny whoop: 1


#52

@quadlifepro: If at first you don’t succeed, try again! :wink:

Seriously, nothing wrong with setting a project aside. This is a hobby, not school or a job. It’s supposed to be fun and relaxing, not stressful and frustrating. :slight_smile:

On a related note, this is one of the reasons I feel like my build-to-fly ratio is out of balance. Building involves so many hurdles for me. So I get paralyzed and procrastinate on my builds, and never get to the flying part. I feel like I have it all wrong. Tinkering is fun. But it’s the flying that’s relaxing and gets me in the zone. Now that Spring’s around the corner, I really, really, need to focus on flying more. :blush:


#53

That’s so funny - I wonder of the extreme difference in the seasons is what tips your balance towards wanting to fly more since it gets taken away from you part of the year. Here in sunny Florida - it’s not cold or snow that locks us down - but rain. Other than that - the hole year is great flying weather. My build to fly ratio is tipped hard towards the build side. I guess I just feel like since I can fly anytime - that I want something nicer to fly. I only experience seasons via YouTube when the videos all shift from flying to building & vlogging. Hahaha


#54

That certainly makes sense. Might also be connected to short days, lack of sun, and Vitamin D deficiency. :wink:

LOL, @NotFastEnuf! :joy:

I can relate to what you’re saying with sun and rain. Lived in tropical West Africa for a few years recently, which coincided with the time I really got into quads. The place had three rainy seasons (!), which often felt kinda like winter. Plenty warm, but torrential rain and overcast and depressing. :neutral_face:


#55

@Brainstorm I totally agree, and understand, trying to set up that whoop certainly felt like work… I just can’t give my money to something that says “bnf” compatible with all spektrum radios then gives me trouble binding and failsafes into the next room… I’m used to actual Bnf units binding and being ready to fly, this was bind and cry IMO…

I was a RTF / BNF out the box type of guy… that’s what got me spoiled with flying FPV - the reliability of a vortex 250, that thing crashes SOOOOOO many times and got right back up… every time I wanted to fly I just went out to the field to fly… now ALL my RTFs are broken or I outgrew them so I gave them away, and now I am left having to build my own in order to get my fix of flight…

So far I have built and tuned 1 70g fpv brushed quad, and 1 brushless micro LOS quad… thank goodness I at least have those…

I know what you mean about spending more time tinkering and less time flying. It’s definitely backwards. I suffer from that as well. My problem is I bought everything all at once before even building a quad… i have so many parts just laying around… that must’ve been the addiction to flying that purchased all the parts…

I have 2 brushless projects that need to get finished, and 3 brushed quads that need to be finished…
Sometimes I just want to that RTF feel again tho so that’s why I wanted the bind a whoop, but I’ll just have to wait…
that is a lot of rain… 3 of the 4 seasons like that? I can see the time to build there lol… we got a lot of rain down south but mainly during the summer. I’d say my tinker/flight ratio on a year round basis is now 70/30 lol


#56

What did you pay for that thing on amazon though - it’s like 85 right. For that price I’m sure someone would build, test, and send you something that performs better and works! Hahaha


#57

Exactly 85 bucks lol I’m sure ur right too which is the sad part… why can’t a bro just get his whoop on??? Lmao I’m just messing.

BTW I got to fly a battery for you and a battery for @PJC yesterday with my brushed 70g H.

She flew AMAZING for 70g with that tune I’ve been working on. The flips were so sharp it almost reminded me of brushless stick response… (I was used to a bnf f1 FC and have now seen the difference from a self tuned f3 FC.) thanks again for all the help you guys… I may not have a functioning whoop ATM but you guys taught me a crapload, and to me I’d say that’s more valueable.


#58

My bro kept raiding my whoop collection, after the 4th one, I told him to pony up and prime me the makerfire. That’s how I know it was 85. LOL. I honestly wouldn’t pay that again for it. I’d say go slow boat order the e010s. By the time you miss the whoop it will show up. & I’ll make you a slick canopy for it! It’s cheap and has a lighter fc, lighter frame, better camera, lighter battery, all around better option.


#59

Can anyone who’s owning that makerfire dsm whoop fc confirm that failsafe set up with BF is working.
I set mine to drop but when I turn off my tx motors don’t stop. They spin up and it’s going crazy till I turn on tx again or unplug lipo.
Messed around for an hour with different failsafe settings. Even tried land and set throttle value to 970 which should make it fall out of the sky. Nothing worked.

It’s flying ok so far, but when I fly one floor up in my house (which isn’t a problem with my other Whoops) it sometimes go crazy and doesn’t respond to tx inputs (fly away mode, like described above when I turn of tx). Think it’s a range issue. Repositioned antenna that it’s pointing outwards to the back. No difference.

That remembered me to set up failsafe which I forgot before. But this isn’t working like with all my other quads. Will definitely not fly that thing outdoors.

When I try to get failsafe working I hold the quad in my hand. Throttle up 20% and turn off tx. No way :thinking:.
If the range of this fc isn’t that great I could live with it but if failsafe isn’t working properly that’s a major bummer.

Any input?


#60

@chrisdo When you plug into Betaflight without the tx bound and look in receiver tab are the sliders all at around 1500? I have one rx that settles like that when tx is off, all my other rx go to 1500 for AER but under 1000 for T as it should be. Doubt I’ll ever buy any Makerfire or crazypony products as they are really bad clones with extremely variable quality control. Cheap is cheap once again.